码迷,mamicode.com
首页 >  
搜索关键字:题目    ( 92071个结果
git文件致源码泄露
前言:在一道ctf题的驱动下,我进行了对git和.git文件致源文件泄露的学习。 一、任务 一道ctf题目。 二、确定题目考的点 谷歌关键词:版本管理工具 github ctf 由得到的结果猜测,可能考的点是.git文件导致源文件泄露。 三、对git的粗略学习 其实经常会用到git,例如在用hexo ...
分类:其他好文   时间:2020-01-28 00:09:28    阅读次数:19
编程题
三、编程题 题目 中国文化博大精深,从仓颉造字开始,汉字一直流传到了今天。我们在感叹汉字的源远流长时,也不禁感慨,为什么没有一门使用汉字编程的语言? 汉字真的不能编程吗?最近文言文编程火了一把,吾有一數。曰三。名之曰「甲」。这朴实无华的变量定义无疑不是几千年来中华文化的发展中一朵奇葩。 今天小王同学 ...
分类:其他好文   时间:2020-01-28 00:05:41    阅读次数:13
[IOI2013] dreaming 梦想 题解
由于题目要使最长路径最短,于是很容易想到贪心策略: 每棵树和其它树连边的点一定是这棵树上能走到的最远距离最短的的点(由于本人语文水平太菜,这句话有点绕 qwq) 如果我们把上述的最短距离称作半径 $r$,$1,2,3...$ 是树按照 $r$ 排序后的。那么最后链接成的树应该长这样: 那么最后的答案 ...
分类:其他好文   时间:2020-01-28 00:03:38    阅读次数:17
《计算机网络·自顶向下方法》第七版 第三章 课后习题与问题 答案
非官方答案,本人已尽最大努力(包括参考官方答案),使结果正确,如有错误,请大佬指出 正文: 3.1~3.3节 R1 a .如果只是简单想把信件送到,那么所有的头部信息只需要一个目的地址就够了,题目给出端口号四个字节,所有分组的头部那就只需四个字节 此协议规定,运输层的全部任务就是,将应用层的数据,切 ...
分类:其他好文   时间:2020-01-28 00:02:02    阅读次数:9
GSS3/1 - Can you answer these queries 3/1
这个题集好好,那天我做一下(开个大坑?) 嘛,题目难的是查询,这里就只讲查询了 根据题解,我们用线段树维护3个东西 lx:表示从lx走,所能在给定区间里面的最大值 rx:参考上面 mx:表示在给定区间中间截取一段所能取到的最大值 那么对于题目给定的查询区间(假设其为L,R) 我们用线段树去遍历这个区 ...
分类:其他好文   时间:2020-01-28 00:00:57    阅读次数:7
Java-POJ1008-Maya Calendar
题意:两种纪年方法的转换 水题,根据题目翻译成代码就可以了 居然WA了一次,避坑,output要先输出数据组数,痛心疾首啊!本来可以一次AC的。 1 package poj.ProblemSet; 2 3 import java.util.Scanner; 4 5 public class poj1 ...
分类:编程语言   时间:2020-01-27 23:58:53    阅读次数:9
剑指offer:矩形覆盖
一、题目描述 我们可以用2*1的小矩形横着或者竖着去覆盖更大的矩形。请问用n个2*1的小矩形无重叠地覆盖一个2*n的大矩形,总共有多少种方法? 二、解题思路 使用归纳法分析有以下情况: 当n<=0时:直接返回0 当n=1时:只要一种解法" | ",返回1 当n=2时:有两种解法"="和 "| | " ...
分类:其他好文   时间:2020-01-27 23:56:58    阅读次数:9
8. 字符串转换整数 (atoi)
题目描述: 请你来实现一个 atoi 函数,使其能将字符串转换成整数。 首先,该函数会根据需要丢弃无用的开头空格字符,直到寻找到第一个非空格的字符为止。 当我们寻找到的第一个非空字符为正或者负号时,则将该符号与之后面尽可能多的连续数字组合起来,作为该整数的正负号;假如第一个非空字符是数字,则直接将其 ...
分类:其他好文   时间:2020-01-27 23:49:49    阅读次数:12
[极客大挑战 2019]EasySQL CTF复现
前言 之前复现了一下极客大挑战2019的Havefun感觉非常的简单,应该是我没有参加极客大挑战把,对这些题没啥印象。复现完Havefun之后接着做了做EasySQL发现这也是一道非常基础的题 复现 初次相遇 我们打开题目链接发现是一个充满黑客色彩的登录页面 发现没有注册的功能,题目是EasySQL ...
分类:数据库   时间:2020-01-27 23:49:37    阅读次数:14
编程题
本次题目 中国文化博大精深,从仓颉造字开始,汉字一直流传到了今天。我们在感叹汉字的源远流长时,也不禁感慨,为什么没有一门使用汉字编程的语言? 汉字真的不能编程吗?最近文言文编程火了一把,吾有一數。曰三。名之曰「甲」。这朴实无华的变量定义无疑不是几千年来中华文化的发展中一朵奇葩。 今天小王同学想,文言 ...
分类:其他好文   时间:2020-01-27 23:44:48    阅读次数:11
92071条   1 2 3 4 ... 9208 下一页
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!