码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 3466 Proud Merchants(0-1背包+排序)

时间:2015-08-26 22:36:21      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:

题目来源:hdu 3466 Proud Merchants

Proud Merchants
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 3595 Accepted Submission(s): 1500

Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

Output
For each test case, output one integer, indicating maximum value iSea could get.

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output
5
11
题目大意:
有n个商品,m元钱,每件商品的p表示出售价格,q为一个固定价,只有你的余额大于或等于该商品的q价时,你才可以购买该商品,该商品的价值为v,求你可以购买到的最大价值。
题目分析:
一般当商品包含价格与价值(本身条件超过两个)的时候,都是需要将商品按照价格进行排序,然后使用0-1背包进行查找即可,题需要对商品的(q-p)进行排序,这样做的目的好像是为了使前面更新过的值不影响后面更新的状态。
AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{        //用结构体来存放该商品的q,p,v,便于进行排序处理 
    int p,q,v;
};
node a[10010];
int f[10010];       //存放购买商品的价值 
int cmp(node a,node b)  //将商品的(q-p)值从小到大进行排序 
{
    return (a.q-a.p) < (b.q-b.p);
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(f,0,sizeof(f));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);
        }
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++)            //0-1背包查找 
        {
            for(int j=m;j>=a[i].q;j--)
            {
                f[j]=max(f[j],f[j-a[i].p]+a[i].v);
            }
        }
        printf("%d\n",f[m]); 
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 3466 Proud Merchants(0-1背包+排序)

标签:

原文地址:http://blog.csdn.net/lsgbb/article/details/48009579

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!