码迷,mamicode.com
首页 > 编程语言 > 详细

poj 2352 树状数组

时间:2016-03-20 16:14:35      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.

技术分享

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


 

树状数组水题,题目给的数据已经按照y优先的顺序排好序了,所以连排序都不用,直接边输入边计算当前点的level值。

 

 

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int C[32005],n;
int lowbit(int x)
{
    return x&-x;
}
int sum(int x)      //求前缀和,x向左上爬
{
    int ret=0;
    while(x>0)
    {
        ret+=C[x];
        x-=lowbit(x);
    }
    return ret;
}
void add(int x,int d)     //A[x]加上d,x向右上爬
{
    while(x<=n)
    {
        C[x]+=d;
        x+=lowbit(x);
    }
}

int ans[15005];
int main()
{
    int N,x,y;
    while(scanf("%d",&N)!=EOF)
    {
        n=32003;
        memset(C,0,sizeof(C));
        memset(ans,0,sizeof(ans));
        for(int i=1; i<=N; i++)
        {
            scanf("%d%d",&x,&y);
            x++;y++;
            ans[sum(x)]++;
            add(x,1);
        }
        for(int i=0;i<N;i++){
            printf("%d\n",ans[i]);
        }
    }
}

poj 2352 树状数组

标签:

原文地址:http://www.cnblogs.com/lastone/p/5297832.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!