码迷,mamicode.com
首页 > Web开发 > 详细

HDU-1072 Nightmare

时间:2016-07-05 20:49:59      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:

Nightmare

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 3

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius‘ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius‘ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1 

Sample Output

4
-1
13

Author

Ignatius.L
思路:bfs+贪心。
    time[][]记录时间,ti[][]记录距离爆炸时间,
      重复走的地方除非离爆炸时间变长了,才压入栈中。
         重置时间的位置走过之后可以变为0,因为以后再走,结果相同。
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<climits>
#include<deque>
#include<cstring>
using namespace std;

int dr[4][2]={{1,0},{0,1},{-1,0},{0,-1} };
int n,m,i,j,sx,sy,flag,ans,t,tx,ty;
int mp[10][10],vis[10][10],time[10][10],ti[10][10];
struct node
{
  int x,y;
};
deque<node> s;
int check(int x,int y)
{
    if (x>0 && x<=n && y>0 && y<=m && mp[x][y]!=0)  return 1;
        else return 0;
}
void bfs()
{
    node p;
    s.clear();
    p.x=sx;
    p.y=sy;
    vis[sx][sy]=1;
    s.push_back(p);
    while(!s.empty())
    {
        node q=s.front();
         for(int i=0;i<4;i++)
         {
             int xx=q.x+dr[i][0];
             int yy=q.y+dr[i][1];
             if(check(xx,yy))
             {
                if(vis[xx][yy])
                {
                    if (ti[xx][yy]<ti[q.x][q.y]-1)
                    {
                        ti[xx][yy]=ti[q.x][q.y]-1;
                        time[xx][yy]=time[q.x][q.y]+1;
                        p.x=xx;
                        p.y=yy;
                        s.push_back(p);
                    }
                } else
                 {
                    if(ti[q.x][q.y]-1>0)
                    {
                        p.x=xx;
                        p.y=yy;
                        s.push_back(p);
                        vis[xx][yy]=1;
                        time[xx][yy]=time[q.x][q.y]+1;
                        ti[xx][yy]=ti[q.x][q.y]-1;
                        if(mp[xx][yy]==4)
                            {
                                ti[xx][yy]=6;
                                mp[xx][yy]=0;
                            }
                        if (mp[xx][yy]==3) return;
                    }
                 }

             }
         }
      s.pop_front();
    }
     return;
}

int main()
{
    scanf("%d",&t);
    for(;t>0;t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            scanf("%d",&mp[i][j]);
            if (mp[i][j]==2) sx=i,sy=j;
            if (mp[i][j]==3) tx=i,ty=j;
        }
        ans=INT_MAX;
        flag=0;
        memset(vis,0,sizeof(vis));
        memset(ti,0,sizeof(ti));
        memset(time,-1,sizeof(time));
        ti[sx][sy]=6;
        time[sx][sy]=0;
        bfs();
        /*if(flag) printf("%d\n",ans);
          else printf("-1\n");*/
        printf("%d\n",time[tx][ty]);
       /* printf("------------------\n");
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
                 printf("%d ",ti[i][j]);
            printf("\n");
        }*/
    }
    return 0;
}

 

 

HDU-1072 Nightmare

标签:

原文地址:http://www.cnblogs.com/stepping/p/5644853.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!