码迷,mamicode.com
首页 > 编程语言 > 详细

POJ2774 Long Long Message [后缀数组]

时间:2016-12-30 02:15:44      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:等价   about   let   i+1   mon   dea   ica   text   different   

Long Long Message
Time Limit: 4000MS   Memory Limit: 131072K
Total Submissions: 29277   Accepted: 11887
Case Time Limit: 1000MS

Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother. 

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out: 

1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 
2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 
3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 
E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 
4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

Background: 
The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

Why ask you to write a program? There are four resions: 
1. The little cat is so busy these days with physics lessons; 
2. The little cat wants to keep what he said to his mother seceret; 
3. POJ is such a great Online Judge; 
4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27

Source

POJ Monthly--2006.03.26,Zeyuan Zhu,"Dedicate to my great beloved mother."

最长公共子串
 

字符串的任何一个子串都是这个字符串的某个后缀的前缀。

求 A 和 B 的最长公共子串等价于求 A 的后缀和 B 的后缀的最长公共前缀的最大值。

两个字符串,考虑合并到一起,用一个没出现过的字符隔开

height中sa[i]和sa[i-1]不在同一个串里的最大值就是答案

这个值一定存在,因为排序后中两个串都有,至少存在一个分界一边是A一边是B

 

//
//  main.cpp
//  poj274
//
//  Created by Candy on 2016/12/27.
//  Copyright © 2016年 Candy. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=2e5+5;
int n,n1,n2,m,a[N];
char s[N];
int sa[N],c[N],t1[N],t2[N];
inline bool cmp(int *r,int a,int b,int j){
    return a+j<=n&&b+j<=n&&r[a]==r[b]&&r[a+j]==r[b+j];
}
int rnk[N],height[N];
void getHeight(int s[]){
    int k=0;
    for(int i=1;i<=n;i++) rnk[sa[i]]=i;
    for(int i=1;i<=n;i++){
        if(k) k--;
        if(rnk[i]==1) continue;
        int j=sa[rnk[i]-1];
        while(i+k<=n&&j+k<=n&&s[i+k]==s[j+k]) k++;
        height[rnk[i]]=k;
    }
}
void getSA(int s[]){
    int *r=t1,*k=t2;
    for(int i=0;i<=m;i++) c[i]=0;
    for(int i=1;i<=n;i++) c[r[i]=s[i]]++;
    for(int i=1;i<=m;i++) c[i]+=c[i-1];
    for(int i=n;i>=1;i--) sa[c[r[i]]--]=i;
    
    for(int j=1;j<=n;j<<=1){
        int p=0;
        for(int i=n-j+1;i<=n;i++) k[++p]=i;
        for(int i=1;i<=n;i++) if(sa[i]>j) k[++p]=sa[i]-j;
        
        for(int i=0;i<=m;i++) c[i]=0;
        for(int i=1;i<=n;i++) c[r[k[i]]]++;
        for(int i=1;i<=m;i++) c[i]+=c[i-1];
        for(int i=n;i>=1;i--) sa[c[r[k[i]]]--]=k[i];
        
        swap(r,k);p=0;r[sa[1]]=++p;
        for(int i=2;i<=n;i++) r[sa[i]]=cmp(k,sa[i],sa[i-1],j)?p:++p;
        if(p>=n) break;m=p;
    }
}
void solve(){
    int mx=0;
    for(int i=2;i<=n;i++){
        if((sa[i]>n1&&sa[i-1]<n1)||(sa[i-1]>n1&&sa[i]<n1)) mx=max(mx,height[i]);
    }
    printf("%d",mx);
}
int main(){
    scanf("%s",s+1);
    n1=strlen(s+1);
    for(int i=1;i<=n1;i++) a[i]=s[i];
    a[++n1]=1;
    scanf("%s",s+1);
    n2=strlen(s+1);
    for(int i=1;i<=n2;i++) a[i+n1]=s[i];
    n=n1+n2; //printf("%d %d %d\n",n1,n2,n);
    m=300;
    getSA(a);
    getHeight(a);
    solve();
    return 0;
}

 

 

 

 

 

POJ2774 Long Long Message [后缀数组]

标签:等价   about   let   i+1   mon   dea   ica   text   different   

原文地址:http://www.cnblogs.com/candy99/p/6235145.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!