码迷,mamicode.com
首页 > 编程语言 > 详细

pojWindow Pains(拓扑排序)

时间:2017-05-22 13:47:47      阅读:264      评论:0      收藏:0      [点我收藏+]

标签:rip   body   exists   sts   its   strcmp   limited   series   idt   

题目链接:

题意:
一快屏幕分非常多区域,区域之间能够相互覆盖,要覆盖就把属于自己的地方所有覆盖。

给出这块屏幕终于的位置。看这块屏幕是对的还是错的。。
思路:
拓扑排序,这个简化点说,就是说跟楚河汉界一样。。分的清清楚楚,要么这块地方是我的,要么这块地方是你的,不纯在一人一办的情况,所以假设排序的时候出现了环,那么就说这快屏幕是坏的。。

。另一点细节要注意的是第i个数字究竟属于第几行第几列。所以这个要发现规律,然后一一枚举就能够了。。


题目:

Window Pains
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1588   Accepted: 792

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux‘s windows would be represented by the following 2 x 2 windows: 
1 1 . .
1 1 . .
. . . .
. . . .
. 2 2 .
. 2 2 .
. . . .
. . . .
. . 3 3
. . 3 3
. . . .
. . . .
. . . .
4 4 . .
4 4 . .
. . . .
. . . .
. 5 5 .
. 5 5 .
. . . .
. . . .
. . 6 6
. . 6 6
. . . .
. . . .
. . . .
7 7 . .
7 7 . .
. . . .
. . . .
. 8 8 .
. 8 8 .
. . . .
. . . .
. . 9 9
. . 9 9
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?

1 2 2 ?
? ? ? ?

? ?

? ?

If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?

4 4 ? ?

?

? ? ?

. . . and so on . . . 
Unfortunately, Boudreaux‘s computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
  1. Start line - A single line: 
    START 

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux‘s screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space. 
  3. End line - A single line: 
    END 

After the last data set, there will be a single line: 
ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux‘s screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN 

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

Source


代码为:

#include<cstdio>
#include<iostream>
#include<vector>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=5+10;
int map[maxn][maxn],in[maxn];

queue<int>Q;
vector<int>vec[maxn];
int dx[]={0,0,1,1};
int dy[]={0,1,0,1};

int topo()
{
    int sum=9;
    while(!Q.empty())  Q.pop();
    for(int i=1;i<=9;i++)
    {
        if(in[i]==0)
            Q.push(i);
    }
    while(!Q.empty())
    {
        int temp=Q.front();
        Q.pop();
        sum--;
        for(int i=0;i<vec[temp].size();i++)
        {
            if(--in[vec[temp][i]]==0)
                Q.push(vec[temp][i]);
        }
    }
    if(sum>0)  return 0;
    else    return 1;
}

void init()
{
    char str[10];
    for(int i=1;i<=9;i++)
    {
        vec[i].clear();
        in[i]=0;
    }
    for(int i=1;i<=9;i++)
    {
        int x=(i-1)/3+1;
        int y=i%3==0?

3:i%3; for(int j=0;j<=3;j++) { int tx=x+dx[j]; int ty=y+dy[j]; if(map[tx][ty]!=i) { vec[i].push_back(map[tx][ty]); in[map[tx][ty]]++; } } } scanf("%s",str); } void solve() { int ans=topo(); if(ans) cout<<"THESE WINDOWS ARE CLEAN"<<endl; else cout<<"THESE WINDOWS ARE BROKEN"<<endl; } int main() { char str[10]; while(~scanf("%s",str)) { if(strcmp(str,"ENDOFINPUT")==0) return 0; for(int i=1;i<=4;i++) for(int j=1;j<=4;j++) scanf("%d",&map[i][j]); init(); solve(); } return 0; }



pojWindow Pains(拓扑排序)

标签:rip   body   exists   sts   its   strcmp   limited   series   idt   

原文地址:http://www.cnblogs.com/yfceshi/p/6888800.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!