码迷,mamicode.com
首页 > 编程语言 > 详细

求助 一个很简单的ACM题 java代码 自己电脑上测都是正确的 但提交总是wrong answer 先谢谢了

时间:2014-09-02 17:12:54      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   java   strong   ar   

题意大致是,给出直角三角形a,b,c(c为斜边)中两个的值(都是正数),求值为-1的那个边。比如3 4 -1,就是求c的长度,输入0 0 0表结束,输出格式如下加粗部分,我自己测自己的运行结果都是正确的,不知为什么总是wa,求大神指点!

Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora‘s Law.

Here we consider the problem of computing the length of the third side, if two are given.

bubuko.com,布布扣

Input

The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the ‘unknown‘ side), the others are positive (the ‘given‘ sides).

A description having a=b=c=0 terminates the input.


Output

For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the ‘given‘ side lengths. Otherwise output the length of the ‘unknown‘ side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.


Sample Input

3 4 -1
-1 2 7
5 -1 3
0 0 0


Sample Output

Triangle #1
c = 5.000

Triangle #2
a = 6.708

Triangle #3
Impossible.

我的代码

import java.text.DecimalFormat;
import java.util.Scanner;

public class Geometry1241 {

static double a, b, c, result;

public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner sc = new Scanner(System.in);
int temp = 1;
String No = "Impossible.";
DecimalFormat df = new DecimalFormat("#.000");
while (sc.hasNext()) {
a = sc.nextInt();
b = sc.nextInt();
c = sc.nextInt();
if (a == b && b == c && c == 0)
break;
if (a == -1) {
result = c * c - b * b;
if (result <= 0 || c <= 0 || b <= 0) {
System.out.println("Triangle #" + temp);
System.out.println(No);
continue;
} else {
a = Math.sqrt(result);
System.out.println("Triangle #" + temp);
System.out.println("a = " + df.format(a));
}
}
if (b == -1) {
result = c * c - a * a;
if (result <= 0 || c <= 0 || a <= 0) {
System.out.println("Triangle #" + temp);
System.out.println(No);
continue;
} else {
b = Math.sqrt(result);
System.out.println("Triangle #" + temp);
System.out.println("b = " + df.format(b));
}
}
if (c == -1) {
if (a <= 0 || b <= 0) {
System.out.println("Triangle #" + temp);
System.out.println(No);
}
result = a * a + b * b;
c = Math.sqrt(result);
System.out.println("Triangle #" + temp);
System.out.println("c = " + df.format(c));

}
temp++;
System.out.println();
}

}

}

求助 一个很简单的ACM题 java代码 自己电脑上测都是正确的 但提交总是wrong answer 先谢谢了

标签:des   style   http   color   os   io   java   strong   ar   

原文地址:http://www.cnblogs.com/mafang/p/3951553.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!