码迷,mamicode.com
首页 > Web开发 > 详细

Command Network

时间:2014-05-10 05:27:44      阅读:475      评论:0      收藏:0      [点我收藏+]

标签:des   style   code   tar   ext   color   

Command Network

Time Limit: 1000MS
Memory Limit: 131072K

Total Submissions: 11970
Accepted: 3482

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy
 
完全是照着别人的代码打出来的,第一道最小树形图
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
#include <cmath>
using namespace std;
typedef long long ll;
const double INF=1<<30;
const int N=105;
const int M=10010;
int vis[N],id[N];
int n,m,ecnt,pre[N];
double in[N];

struct edge{
     int u,v;
     double w;
     edge( ) {}
     edge(int u,int v,double w):u(u),v(v),w(w) {}
}e[M];

struct node
{
    double x,y;
}point[N];

double getdis(node a,node b)
{
    double x=a.x-b.x;
    double y=a.y-b.y;
    return sqrt(x*x+y*y);
}

double MST(int root,int n,int m)
{
    double res=0;
    while(1)
    {
        for(int i = 0; i < n; i++)
           in[i] = INF;
        for(int i = 0; i < m; i++)
        {
            int u = e[i].u;
            int v = e[i].v;
            if(e[i].w < in[v] && u != v)
              {pre[v] = u; in[v] = e[i].w;}
        }
        for(int i = 0; i < n; i++)
        {
            if(i == root) continue;
            if(in[i] == INF) return -1;//除了根以外有点没有入边,则根无法到达它
        }
        //2.找环
        int cnt = 0;
        memset(id, -1, sizeof(id));
        memset(vis, -1, sizeof(vis));
        in[root] = 0;
        for(int i = 0; i < n; i++) //标记每个环
        {
            res += in[i];
            int v = i;
            while(vis[v] != i && id[v] == -1 && v != root)  //每个点寻找其前序点,要么最终寻找至根部,要么找到一个环
            {
                vis[v] = i;
                v = pre[v];
            }
            if(v != root && id[v] == -1)//缩点
            {
                for(int u = pre[v]; u != v; u = pre[u])
                    id[u] = cnt;
                id[v] = cnt++;
            }
        }
        if(cnt == 0) break; //无环   则break
        for(int i = 0; i < n; i++)
            if(id[i] == -1) id[i] = cnt++;
        for(int i = 0; i < m; i++)
        {
            int u = e[i].u;
            int v = e[i].v;
            e[i].u = id[u];
            e[i].v = id[v];
            if(id[u] != id[v]) e[i].w -= in[v];
        }
        n = cnt;
        root = id[root];
    }
    return res;
}

void solve()
{
    for(int i=0; i<n; i++) scanf("%lf%lf",&point[i].x,&point[i].y);
    ecnt=0;
    int u,v;
    for(int i=0; i<m; i++)
    {
        scanf("%d%d",&u,&v);
        if(u==v) continue;
        u--; v--;
        double dis=getdis(point[u],point[v]);
        e[ecnt++]=edge(u,v,dis);
    }
    double ans=MST(0,n,ecnt);
    if(ans == -1) printf("poor snoopy\n");
    else printf("%.2f\n", ans);
}

int main()
{
    while(scanf("%d%d",&n,&m)>0) solve();
    return 0;
}

Command Network,布布扣,bubuko.com

Command Network

标签:des   style   code   tar   ext   color   

原文地址:http://www.cnblogs.com/zyx1314/p/3719542.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!