码迷,mamicode.com
首页 > Web开发 > 详细

poj 2570 Fiber Network (Floyd)

时间:2014-09-06 17:26:33      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   使用   ar   strong   

Fiber Network
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3107   Accepted: 1427

Description

Several startup companies have decided to build a better Internet, called the "FiberNet". They have already installed many nodes that act as routers all around the world. Unfortunately, they started to quarrel about the connecting lines, and ended up with every company laying its own set of cables between some of the nodes. 
Now, service providers, who want to send data from node A to node B are curious, which company is able to provide the necessary connections. Help the providers by answering their queries.

Input

The input contains several test cases. Each test case starts with the number of nodes of the network n. Input is terminated by n=0. Otherwise, 1<=n<=200. Nodes have the numbers 1, ..., n. Then follows a list of connections. Every connection starts with two numbers A, B. The list of connections is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the unidirectional connection, respectively. For every connection, the two nodes are followed by the companies that have a connection from node A to node B. A company is identified by a lower-case letter. The set of companies having a connection is just a word composed of lower-case letters. 
After the list of connections, each test case is completed by a list of queries. Each query consists of two numbers A, B. The list (and with it the test case) is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the query. You may assume that no connection and no query contains identical start and end nodes.

Output

For each query in every test case generate a line containing the identifiers of all the companies, that can route data packages on their own connections from the start node to the end node of the query. If there are no companies, output "-" instead. Output a blank line after each test case.bubuko.com,布布扣

Sample Input

3
1 2 abc
2 3 ad
1 3 b
3 1 de
0 0
1 3
2 1
3 2
0 0
2
1 2 z
0 0
1 2
2 1
0 0
0

Sample Output

ab
d
-

z
-

公司使用小写字母表示的,最多26个公司,故可以用二进制的位来表示公司。


#include"stdio.h"
#include"string.h"
#include"vector"
#include"queue"
#include"iostream"
#include"algorithm"
using namespace std;
#define N 205
const int inf=(int)1e10;
int g[N][N];
int main()
{
    int i,j,k,n,a,b;
    char str[27];
    while(scanf("%d",&n),n)
    {
        memset(g,0,sizeof(g));
        while(scanf("%d%d",&a,&b),a||b)
        {
            scanf("%s",str);
            for(i=0;str[i]!='\0';i++)      //某一位上为一代表该公司可以连接a,b
                g[a][b]|=1<<(str[i]-'a');
        }
        for(k=1;k<=n;k++)
        {
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    g[i][j]|=(g[i][k]&g[k][j]);
                }
            }
        }
        while(scanf("%d%d",&a,&b),a||b)
        {
            if(!g[a][b])
            {
                printf("-\n");
                continue;
            }
            for(char i='a';i<='z';i++)
            {
                if(g[a][b]&(1<<i-'a'))
                    printf("%c",i);
            }
            puts("");
        }
        puts("");
    }
    return 0;
}



poj 2570 Fiber Network (Floyd)

标签:des   style   http   color   os   io   使用   ar   strong   

原文地址:http://blog.csdn.net/u011721440/article/details/39101927

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!