码迷,mamicode.com
首页 > 编程语言 > 详细

AOJ GRL_1_B: Shortest Path - Single Source Shortest Path (Negative Edges) (Bellman-Frod算法求负圈和单源最短路径)

时间:2017-10-25 00:51:33      阅读:328      评论:0      收藏:0      [点我收藏+]

标签:tput   wrapper   else   lines   res   tor   ati   break   jsp   

题目链接:

  http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=GRL_1_B

 

 

 

Single Source Shortest Path (Negative Edges)


Input

An edge-weighted graph G (VE) and the source r.

|V| |E| r
s0 t0 d0
s1 t1 d1
:
s|E|?1 t|E|?1 d|E|?1

|V| is the number of vertices and |E| is the number of edges in G. The graph vertices are named with the numbers 0, 1,..., |V|?1 respectively. r is the source of the graph.

si and ti represent source and target vertices of i-th edge (directed) and di represents the cost of the i-th edge.

Output

If the graph contains a negative cycle (a cycle whose sum of edge costs is a negative value) which is reachable from the source r, print

NEGATIVE CYCLE

in a line.

Otherwise, print

c0
c1
:
c|V|?1

The output consists of |V| lines. Print the cost of the shortest path from the source r to each vertex 0, 1, ... |V|?1 in order. If there is no path from the source to a vertex, print "INF".

Constraints

  • 1 ≤ |V| ≤ 1000
  • 0 ≤ |E| ≤ 2000
  • -10000 ≤ di ≤ 10000
  • There are no parallel edges
  • There are no self-loops

Sample Input 1

4 5 0
0 1 2
0 2 3
1 2 -5
1 3 1
2 3 2

Sample Output 1

0
2
-3
-1

Sample Input 2

4 6 0
0 1 2
0 2 3
1 2 -5
1 3 1
2 3 2
3 1 0

Sample Output 2

NEGATIVE CYCLE

Sample Input 3

4 5 1
0 1 2
0 2 3
1 2 -5
1 3 1
2 3 2

Sample Output 3

INF
0
-5
-3

 

 

 

 

这题求单源最短路径+负圈,用Bellman-Ford算法。

注意:这里求的负圈附带了条件,就是源点r能触及到的负圈。

 

Bellman-Ford算法+求负圈链接

 

 

代码:

#include <iostream>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;
typedef long long ll;
#define INF 2147483647

struct edge{
    int from,to,cost; 
};

edge es[2010];  //存储边 

int d[1010];  // d[i] 表示点i离源点的最短距离 

int V,E; //点和边的数量 



bool shortest_path(int s){
    fill(d,d+V,INF);
    
    d[s] = 0;
    
    int v = 0;
    while(true){
        bool update = false;
        for(int i = 0;i < E; i++){
            edge e = es[i];
            if(d[e.from] != INF && d[e.to] > d[e.from] + e.cost){
                d[e.to] = d[e.from] + e.cost;
                update = true;
                if(v == V-1) return true;
            }
        }
        if(!update) break;
        v++;
    }
    return false;
}


int main(){
    
    int r;
    cin >> V >> E >> r;

    for(int i = 0;i < E; i++) cin >> es[i].from >> es[i].to >>es[i].cost;
    
    if(!shortest_path(r)){
        for(int i = 0;i < V; i++){
            if(d[i] == INF) cout <<"INF" <<endl;
            else cout << d[i] << endl;
        }
    }else{
        cout <<"NEGATIVE CYCLE" <<endl;
    }
    

    return 0;
} 

 

AOJ GRL_1_B: Shortest Path - Single Source Shortest Path (Negative Edges) (Bellman-Frod算法求负圈和单源最短路径)

标签:tput   wrapper   else   lines   res   tor   ati   break   jsp   

原文地址:http://www.cnblogs.com/zhangjiuding/p/7726211.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!