码迷,mamicode.com
首页 > 编程语言 > 详细

POJ2828 Buy Tickets 树状数组

时间:2018-04-28 22:23:34      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:HERE   暴力   minus   sele   sch   follow   for   sample   was   

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

技术分享图片

Source

 
提交地址 : Buy Tickets 
 
题目大意 : 来了n个人, 每个人在队列里选择了一个位置插入, 问最后的序列是什么样的;
 
分析:
时光倒流:因为最后的人肯定是站在自己想占的地方, 所以从后往前便于处理;
首先设一个人都没有, 序列全部为1(后面讲为什么);
然后插入最后一个人, 那样例二来说, 他肯定是插在了自己想在的地方, 所以把他所站的地方设为0, 序序列便成为了 0 1 1 1;
然后考虑倒数第二个人, 他要去第二的位置但是在他之前已经插入了最后一个人, 所以他最终的位置一定不是在第二个位置;
那是在第几个位置呢? 答案是:第二个1!为什么, 因为1表示此位置还未被占, 所以他要站在第二个没有被占得位置上;
求前缀1的值我们可以用树状数组维护(这就是初始值是1的原因!);
但是对于没个人都要枚举一遍显然是不现实的, 又因为前缀和满足单调性, 所以直接暴力二分OK;
 
应该特别好理解;
不理解的看看代码就差不多了;
代码奉上:
 
技术分享图片
//By zZhBr
#include <iostream>
#include <cstdio> 
#include <algorithm>
using namespace std;

int n;


struct pro
{
    int pos;
    int num;
}pr[200010];

int ans[200010];

int tr[200010];

int lowbit(int x)
{
    return x & -x;
}

void add(int x, int y)
{
    while(x <= n)
    {
        tr[x] += y;
        x += lowbit(x);
    }
}

int sum(int x)
{
    int ans = 0;
    while(x != 0)
    {
        ans += tr[x];
        x -= lowbit(x);
    }
    return ans;
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        for(register int i = 1 ; i <= n ; i ++) ans[i] = 0;
        for(register int i = 1 ; i <= n ; i ++)
        {
            scanf("%d%d", &pr[i].pos, &pr[i].num);
            add(i, 1);
        }
        
        for(register int i = n ; i >= 1 ; i --)
        {
            int p = pr[i].pos + 1;
            
            if(sum(p) == p)
            {
                ans[p] = pr[i].num;
                add(p, -1);
                continue;
            }
            
            int l = p, r = n;
            while(l  < r)
            {
                int mid = l + r >> 1;
                if(sum(mid) >= p) r = mid;
                else l = mid + 1;
            }
            
            ans[l] = pr[i].num;
            add(l, -1);
            
        }
        
        for(register int i = 1 ; i <= n ; i ++)
        {
            printf("%d ", ans[i]);
        }
        printf("\n");
        
    }
    return 0;
}
zZhBr

 

 
 

POJ2828 Buy Tickets 树状数组

标签:HERE   暴力   minus   sele   sch   follow   for   sample   was   

原文地址:https://www.cnblogs.com/zZh-Brim/p/8969424.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!