码迷,mamicode.com
首页 > 编程语言 > 详细

HDU2255 奔小康赚大钱 【二分图最佳匹配·KM算法】

时间:2014-10-11 12:16:15      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:hdu2255

奔小康赚大钱

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3898    Accepted Submission(s): 1691


Problem Description
传说在遥远的地方有一个非常富裕的村落,有一天,村长决定进行制度改革:重新分配房子。
这可是一件大事,关系到人民的住房问题啊。村里共有n间房间,刚好有n家老百姓,考虑到每家都要有房住(如果有老百姓没房子住的话,容易引起不安定因素),每家必须分配到一间房子且只能得到一间房子。
另一方面,村长和另外的村领导希望得到最大的效益,这样村里的机构才会有钱.由于老百姓都比较富裕,他们都能对每一间房子在他们的经济范围内出一定的价格,比如有3间房子,一家老百姓可以对第一间出10万,对第2间出2万,对第3间出20万.(当然是在他们的经济范围内).现在这个问题就是村领导怎样分配房子才能使收入最大.(村民即使有钱购买一间房子但不一定能买到,要看村领导分配的).
 

Input
输入数据包含多组测试用例,每组数据的第一行输入n,表示房子的数量(也是老百姓家的数量),接下来有n行,每行n个数表示第i个村名对第j间房出的价格(n<=300)。
 

Output
请对每组数据输出最大的收入值,每组的输出占一行。

 

Sample Input
2 100 10 15 23
 

Sample Output
123
 

Source
 

题意:求二分图最佳匹配的模板题。

题解:开始用了书上的模板,看到四层for循环顿时冒汗-_-|||结果敲下来后发现无法运行..然后在网上找了个模板,原链接



#include <stdio.h>
#include <string.h>

#define maxn 305
#define inf 0x3f3f3f3f

int G[maxn][maxn];
int Lx[maxn], Ly[maxn];
int match[maxn];
bool visx[maxn], visy[maxn];
int slack[maxn], n;

bool DFS(int cur) {
    int t, y;
    visx[cur] = true;
    for(y = 1; y <= n; ++y) {
        if(visy[y]) continue;
        t = Lx[cur] + Ly[y] - G[cur][y];
        if(t == 0) {
            visy[y] = true;
            if(match[y] == -1 || DFS(match[y])) {
                match[y] = cur; return true;
            }
        } else if(slack[y] > t) slack[y] = t; 
    }
    return false;
}

int KM() {
    int i, j, x, d, ret;
    memset(match, -1, sizeof(int) * (n + 1));
    memset(Ly, 0, sizeof(int) * (n + 1));
    for(i = 1; i <= n; ++i) {
        Lx[i] = -inf;
        for(j = 1; j <= n; ++j)
            if(G[i][j] > Lx[i]) Lx[i] = G[i][j];
    }
    for(x = 1; x <= n; ++x) {
        memset(slack, 0x3f, sizeof(int) * (n + 1));
        while(true) {
            memset(visx, 0, sizeof(bool) * (n + 1));
            memset(visy, 0, sizeof(bool) * (n + 1));
            if(DFS(x)) break;
            d = inf;
            for(i = 1; i <= n; ++i)
                if(!visy[i] && d > slack[i]) 
                    d = slack[i];
            for(i = 1; i <= n; ++i)
                if(visx[i]) Lx[i] -= d;
            for(i = 1; i <= n; ++i)
                if(visy[i]) Ly[i] += d;
                else slack[i] -= d;
        }
    }
    ret = 0;
    for(i = 1; i <= n; ++i)
        if(match[i] > -1) ret += G[match[i]][i];
    return ret;
}

int main() {
    // freopen("stdin.txt", "r", stdin);
    int i, j;
    while(scanf("%d", &n) == 1) {
        for(i = 1; i <= n; ++i)
            for(j = 1; j <= n; ++j)
                scanf("%d", &G[i][j]);
        printf("%d\n", KM());
    }
    return 0;
}


HDU2255 奔小康赚大钱 【二分图最佳匹配·KM算法】

标签:hdu2255

原文地址:http://blog.csdn.net/chang_mu/article/details/39989573

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!