码迷,mamicode.com
首页 > 编程语言 > 详细

Java练习 SDUT-2670_3-1 Point类的构造函数

时间:2018-11-06 11:20:02      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:vat   重构   ann   print   private   des   目的   括号   scanner   

3-1 Point类的构造函数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

通过本题目的练习可以掌握类的构造函数的定义;

设计一个点类Point,私有数据成员有x、y;公有成员函数有:无参数的构造函数Point(),带参数的构造函数Point(int,int);ShowPoint()输出点对象的信息

在主函数main()中调用相应成员函数,从键盘接收时间对象的x和y的值,并向显示器输出相应的值。

Input

输入2个整数,用一个空格间隔

Output

要求先输出默认的点值,再输出用户构造的点的值

点的格式为:一对圆括号内 x,y的值,中间用“,”间隔;

Sample Input

10 11

Sample Output

(0,0)
(10,11)

重构函数,关于输出有点迷,初始值在输入前后输出都可以。

import java.util.*;

public class Main {
    public static void main(String[] args)
    {
        Scanner cin = new Scanner(System.in);
        point a = new point();
        a.show();
        a = new point(cin.nextInt(),cin.nextInt());
        a.show();
        cin.close();
    }
}


class point
{
    private int x,y;
    public point()
    {
        x = 0;
        y = 0;
    }
    public point(int x,int y)
    {
        this.x = x;
        this.y = y;
    }
    public void show()
    {
        System.out.printf("(%d,%d)\n",x,y);
    }
}

Java练习 SDUT-2670_3-1 Point类的构造函数

标签:vat   重构   ann   print   private   des   目的   括号   scanner   

原文地址:https://www.cnblogs.com/luoxiaoyi/p/9913148.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!