码迷,mamicode.com
首页 > 编程语言 > 详细

PAT 甲级 1028 List Sorting (25 分)(排序,简单题)

时间:2019-08-18 15:55:40      阅读:87      评论:0      收藏:0      [点我收藏+]

标签:ram   exce   otto   ring   first   bit   main   HERE   who   

1028 List Sorting (25 分)
 

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student‘s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID‘s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID‘s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

 

思路:

简单,三种排序可能,cmp写一下

AC代码:

 

#include<bits/stdc++.h>
using namespace std;
struct node
{
    string num;
    string name;
    int score;
}a[100005];
bool cmp1(node x,node y){
    return x.num<y.num;
};
bool cmp2(node x,node y){
    if(x.name==y.name){
        return x.num<y.num;
    }
    else return x.name<y.name;
};
bool cmp3(node x,node y){
    if(x.score==y.score){
        return x.num<y.num;
    }
    else return x.score<y.score;
};
int main()
{
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++){
        cin>>a[i].num>>a[i].name>>a[i].score;
    }
    if(m==1){
        sort(a+1,a+1+n,cmp1);
    }else if(m==2){
        sort(a+1,a+1+n,cmp2);
    }else{
        sort(a+1,a+1+n,cmp3);
    }
    for(int i=1;i<=n;i++){
        cout<<a[i].num<<" "<<a[i].name<<" "<<a[i].score<<endl;
    }
    return 0;
}

 

PAT 甲级 1028 List Sorting (25 分)(排序,简单题)

标签:ram   exce   otto   ring   first   bit   main   HERE   who   

原文地址:https://www.cnblogs.com/caiyishuai/p/11372233.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!