码迷,mamicode.com
首页 > 编程语言 > 详细

python升级带来的yum异常(解决错误File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:)

时间:2019-10-20 19:53:04      阅读:30      评论:0      收藏:0      [点我收藏+]

标签:tab键   int   错误   解决方法   哪些   http   异常   默认   原因   

解决错误File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:

错误:

 技术图片

 

 

原因:

这是因为yum采用python作为命令解释器,原来系统自带的python解释器为python2.7,然后我之前为了方便将python默认的解释器设为了python3.6,导致按python3.6解析2.7的语法出错了。

解决方法:

修改/usr/bin/yum文件中的第一行为#!/usr/bin/python2.7

 技术图片

 

 

可能你的系统不是2.7,通过tab键补全python命令就可以看到你有哪些python版本,选一个低版本的就好。

 技术图片

 

 

修改之后就可以正常使用yum了。

技术图片

 

python升级带来的yum异常(解决错误File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:)

标签:tab键   int   错误   解决方法   哪些   http   异常   默认   原因   

原文地址:https://www.cnblogs.com/zmdComeOn/p/11708677.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!