码迷,mamicode.com
首页 > 编程语言 > 详细

蓝桥算法训练 数据交换 ALGO-221

时间:2020-03-16 23:16:24      阅读:76      评论:0      收藏:0      [点我收藏+]

标签:color   使用   define   math   调用   scanf   一个   stream   主函数   

问题描述


  编写一个程序,输入两个整数,分别存放在变量x和y当中,然后使用自己定义的函数swap来交换这两个变量的值。
  输入格式:输入只有一行,包括两个整数。
  输出格式:输出只有一行,也是两个整数,即交换以后的结果。
  要求:主函数负责数据的输入与输出,但不能直接交换这两个变量的值,必须通过调用单独定义的函数swap来完成,而swap函数只负责交换变量的值,不能输出交换后的结果。

样例输入

4 7

样例输出

7 4
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

#define INF 0x7fffffff
const double inf=1e20;
const int maxn=1000+10;
const int mod=1e7;
const double pi=acos(-1);

int main(){
    int a,b;
    scanf("%d%d",&a,&b);
    printf("%d %d\n",b,a);
    return 0;
}

 

蓝桥算法训练 数据交换 ALGO-221

标签:color   使用   define   math   调用   scanf   一个   stream   主函数   

原文地址:https://www.cnblogs.com/wz-archer/p/12507683.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!