码迷,mamicode.com
首页 > 系统相关 > 详细

PAT1042 Shuffling Machine (20分) 用1-54代替点数更方便哦

时间:2020-06-11 16:17:02      阅读:66      评论:0      收藏:0      [点我收藏+]

标签:form   result   from   jobs   test   处理   because   job   employees   

题目

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13,
H1, H2, ..., H13,
C1, C2, ..., C13,
D1, D2, ..., D13,
J1, J2
where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目解析

模拟洗牌的过程,刚开始54张牌的状态是 S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2。现给定洗牌次数,以及每次洗牌的规则,要求,输出完成给定次数次洗牌后,最终的牌面状态。

其中,洗牌规则以54个数字的形式给出,第 i 个位置 数字为 j,代表 把第 i 张牌挪到第 j 个位置去。

思路:

  • 首先,为了操作方便,我们把 S1-S13,H1-H13,C1-C13,D1-D13,J1-J2 分别用数字 1-54代替,操作完成后,再转成对应的字符加数字即可。
  • 所谓洗牌规则,把第 i 张牌挪到第 j 个位置去,就是 a[j] = a[i]
  • 由于有多次洗牌,我们要记录每一次洗牌的初始状态,和结束状态,本次结束状态就是下一次的初始状态;
  • 初始时牌面是1-54顺序存放。

完整代码

#include <iostream>
using namespace std;

// 刚开始的牌有序 
// S1, S2, ..., S13,
// H1, H2, ..., H13, 
// C1, C2, ..., C13, 
// D1, D2, ..., D13, 
// J1, J2
// 为了方便处理,直接用1-54代替

int main() {
    // cnt次洗牌
    int cnt;
    cin >> cnt;
    // 每次洗牌,第i个位置的排应该挪到到location[i]的位置去
    // 保存每次洗牌,开始时的状态,按给定的顺序规则洗完后的状态
    int start[55], end[55];
    int location[55];
    for (int i = 1; i <= 54; ++i) {
        cin >> location[i];
        // 按开始状态初始化
        start[i] = i;
    }
    // cnt次洗牌
    while(cnt-- > 0) {
        // 第i个位置的排应该挪到到location[i]的位置去
        for (int i = 1; i<= 54; ++i) {
            end[location[i]] = start[i];
        }
        // 本次洗完后的结果,作为下次洗牌的开始状态
        for (int i = 1; i<= 54; ++i) {
            start[i] = end[i];
        }
    }
    // 结束后,再把1-54转成对应的牌面,1--S1,14--H1,27--C1,40--D1,53--J1
    char c[6] = "SHCDJ";
    for (int i = 1; i <= 54; ++i) {
        end[i] = end[i] - 1;
        printf("%c%d", c[end[i] / 13], end[i] % 13 + 1);
        if (i != 54) cout << " ";
    }
    return 0;

}

PAT1042 Shuffling Machine (20分) 用1-54代替点数更方便哦

标签:form   result   from   jobs   test   处理   because   job   employees   

原文地址:https://www.cnblogs.com/codervivi/p/13093611.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!