码迷,mamicode.com
首页 > 编程语言 > 详细

poj 1258 Agri-Net 最小生成树 prim算法+heap不完全优化

时间:2014-11-13 01:47:11      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:des   blog   io   ar   os   sp   for   strong   div   

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 41230   Accepted: 16810

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

 

#include <cstdio>
#include<cstring>
#include <queue>
#include <assert.h>
using namespace std;

int blen;
int d[102][102];
int n;
bool vis[102];
typedef pair<int,int> P;
int prim(){
    memset(vis,0,sizeof(vis));
    priority_queue<P,vector<P>,greater<P> >que;
    int num=1;
    int ans=0;
    for(int i=1;i<n;i++){
        que.push(P(d[0][i],i));
    }
    vis[0]=true;
    while(num<n&&!que.empty()){
        int t=que.top().second;
        int td=que.top().first;
        que.pop();
        if(vis[t])continue;
        vis[t]=true;
        ans+=td;
        num++;
        for(int i=0;i<n;i++){
            if(!vis[i]){
                que.push(P(d[t][i],i));
            }
        }
    }
    return ans;
}
int main(){
    while(scanf("%d",&n)==1){
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                scanf("%d",d[i]+j);
            }
        }
        int ans=prim();
        printf("%d\n",ans);
    }
    return 0;
}

  

poj 1258 Agri-Net 最小生成树 prim算法+heap不完全优化

标签:des   blog   io   ar   os   sp   for   strong   div   

原文地址:http://www.cnblogs.com/xuesu/p/4093930.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!