码迷,mamicode.com
首页 > 数据库 > 详细

执行DB devices时提示版本不匹配

时间:2021-02-24 13:25:00      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:image   ted   提示   attach   文件   code   match   替换   命令   

重新安装了adb和夜神模拟器后,启动夜神模拟器,并在控制台执行adb devices时总是提示错误:

List of devices attached
adb server version (41) doesn‘t match this client (36); killing...
* daemon started successfully *
127.0.0.1:59865 device

排查过程:

1、输入adb命令时,查看本地adb 的版本为36

List of devices attached
adb server version (41) doesn‘t match this client (36); killing...
* daemon started successfully *
127.0.0.1:59865 device

2、在夜神模拟器的bin下执行nox_adb,查看版本,为41

 

技术图片

 

结果:两个版本不一致

解决办法:

 

1.找到版本号不一样原因了,接下来把android-sdk里面的adb.exe版本复制出来,然后改个名称叫nox_adb.exe,替换nox安装的路径:\Nox\bin下的nox_adb.exe文件就行了

2.接下来关掉夜神模拟器,重启模拟器,在cmd输入adb devices发现还是不行

3.原因:本地的环境变量的path依然为旧的sdk路径,修改环境变量的sdk路径为最新版的sdk即可,重开控制台,输入adb,版本已经一致了。

替换完后,

执行DB devices时提示版本不匹配

标签:image   ted   提示   attach   文件   code   match   替换   命令   

原文地址:https://www.cnblogs.com/bzdmz/p/14439318.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有
迷上了代码!