码迷,mamicode.com
首页 > 编程语言 > 详细

PTA basic 1092 最好吃的月饼 (20 分) c++语言实现(g++)

时间:2021-05-24 09:03:24      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:格式   实现   alt   接下来   std   rgb   name   ott   i++   

月饼是久负盛名的中国传统糕点之一,自唐朝以来,已经发展出几百品种。

技术图片

若想评比出一种“最好吃”的月饼,那势必在吃货界引发一场腥风血雨…… 在这里我们用数字说话,给出全国各地各种月饼的销量,要求你从中找出销量冠军,认定为最好吃的月饼。

输入格式:

输入首先给出两个正整数 N(1000)和 M(100),分别为月饼的种类数(于是默认月饼种类从 1 到 N 编号)和参与统计的城市数量。

接下来 M 行,每行给出 N 个非负整数(均不超过 1 百万),其中第 i 个整数为第 i 种月饼的销量(块)。数字间以空格分隔。

输出格式:

在第一行中输出最大销量,第二行输出销量最大的月饼的种类编号。如果冠军不唯一,则按编号递增顺序输出并列冠军。数字间以 1 个空格分隔,行首尾不得有多余空格。

输入样例:

5 3
1001 992 0 233 6
8 0 2018 0 2008
36 18 0 1024 4
 

输出样例:

2018
3 5

 

#include <iostream>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;
int main(){
    int n,m,temp,max{0};
    cin >> n >> m;
    vector<int> type(n,0);
    for(int i=0;i<m;i++){
        for(int j=0;j<n;j++){
            cin >> temp;
            type[j]+=temp;
            if(type[j]>max)max=type[j];
        }
    }
    cout << max<<endl;
    bool hasfisrt{true};
    for(int i=0;i<n;i++){
        if(type[i]==max){
            if(hasfisrt){
                printf("%d",i+1);
                hasfisrt=false;
            }else{
                printf(" %d",i+1);
            }
        }
    }
    return 0;
}

 

PTA basic 1092 最好吃的月饼 (20 分) c++语言实现(g++)

标签:格式   实现   alt   接下来   std   rgb   name   ott   i++   

原文地址:https://www.cnblogs.com/ichiha/p/14768254.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!