码迷,mamicode.com
首页 > Windows程序 > 详细

Winter-1-F Number Sequence 解题报告及测试数据

时间:2015-02-24 13:44:59      阅读:275      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:1000MS     Memory Limit:32768KB 

Description

?A number sequence is defined as follows:f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

题解:

?因为n过大,f(n-1)和f(n-2)只有0,1,2,3,4,5,6七种情况,又A和B不变,f(n)由f(n-1)和f(n-2)决定,所以至多计算49次后,必将发生循环,所以计算50次即可。              

以下是代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <string>
int c[1000];
using namespace std;
int main(){
    int a,b,n;
    int t1,t2,t;
    c[1]=c[2]=1;
    while(scanf("%d%d%d",&a,&b,&n)!=EOF && (a || b || n)){
        t1 =t2=1;
        int tag=0,i;
        for(i=3;i<=100;i++){
            t = t2;
            t2 = (a*t + b*t1)%7;
            t1 = t ;
            c[i]=t2;
            if(t1==1 && t2==1)break;//发生循环,就终止。
        }
        c[0]=c[i-2];//将循环的最后一个值赋值给c[0],避免取余数后判断
        printf("%d\n",c[n%(i-2)]);//i-2即周期
    }
}

Winter-1-F Number Sequence 解题报告及测试数据

标签:

原文地址:http://www.cnblogs.com/gzdaijie/p/4298092.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!