码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 3067 Japan(树状数组/求逆序数)

时间:2015-04-21 22:46:39      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:

Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22258   Accepted: 5995

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int n,m,k;
__int64 c[1000100];

struct node
{
    int x;
    int y;
} q[1000500];

bool cmp(node a,node b)
{
    if(a.x==b.x)
    {
        return a.y<=b.y;
    }
    else
    {
        return a.x<b.x;
    }
}
int lowbit(int x)
{
    return x&(-x);
}

void updata(int i,int t)
{
    while(i<=m)
    {
        c[i] += t;
        i = i + lowbit(i);
    }
}

__int64 getsum(int i)
{
    __int64 sum = 0;
    while(i>0)
    {
        sum += c[i];
        i = i - lowbit(i);
    }
    return sum;
}

int main()
{
    int T;
    int p = 0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(c,0,sizeof(c));
        for(int i=0; i<k; i++)
        {
            scanf("%d%d",&q[i].x,&q[i].y);
        }
        __int64 ans = 0;
        sort(q,q+k,cmp);
        for(int i=0; i<k; i++)
        {
            updata(q[i].y,1);
            ans += getsum(m) - getsum(q[i].y);
        }
        printf("Test case %d: %I64d\n",++p,ans);
    }
    return 0;
}


POJ 3067 Japan(树状数组/求逆序数)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/45175977

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!