码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 2155 Matrix(树状数组)

时间:2015-04-21 22:53:02      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 20138   Accepted: 7522

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng




      题意:poj1566的二维版,有一个矩阵,矩阵中的每个元素只能有0,1,表示,给定一个矩形的左上角和右下角,在这个矩形中的元素进行取反。当输入的字符为Q是,输出地址为x行y列的那个元素是0还是1.


#include <iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

#define maxn 1005

int a[maxn][maxn];
int r,l;
int n;

inline int Lowbit(int x)
{
    return x & (-x);
}

int Sum(int x, int y)
{
    int temp, sum = 0;
    while (x)
    {
        temp = y;
        while (temp)
        {
            sum += a[x][temp];
            temp -= Lowbit(temp);
        }
        x -= Lowbit(x);
    }
    return sum;
}

void Update(int x, int y, int num)
{
    int temp;
    while (x <= n)
    {
        temp = y;
        while (temp <= n)
        {
            a[x][temp] += num;
            temp += Lowbit(temp);
        }
        x += Lowbit(x);
    }
}

int main()
{
    int x, m;
    scanf("%d", &x);
    while (x--)
    {
        memset(a, 0, sizeof(a));
        scanf("%d%d", &n, &m);
        getchar();
        l = n;
        r = n;
        for (int i = 0; i < m; i++)
        {
            char ch;
            int x1, x2, y2, y1;
            scanf("%c", &ch);
            if (ch == 'C')
            {
                scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
                x2++;
                y2++;
                Update(x1, y1, 1);
                Update(x1, y2, -1);
                Update(x2, y1, -1);
                Update(x2, y2, 1);
            }
            else
            {
                scanf("%d%d", &x1, &y1);
                printf("%d\n", (Sum(x1, y1)%2));
            }
            getchar();
        }
        printf("\n");
    }
    return 0;
}



POJ 2155 Matrix(树状数组)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/45174085

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!