码迷,mamicode.com
首页 > 编程语言 > 详细

hdu Courses 1083 二分匹配 ,匈牙利算法。。水题

时间:2015-04-28 09:40:23      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:hdu1083   dfs   二分匹配   

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4233    Accepted Submission(s): 2014


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you‘ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
YES NO
 水题。匈牙利算法模板题
#include <stdio.h>
#include <string.h>
#define SIZE 350

int pre[SIZE] , p , n ;
bool map[SIZE][SIZE] , vis[SIZE];
int find(int pos)
{
	for(int i = 1 ; i <= n ; ++i)
	{
		if(!vis[i] && map[pos][i])
		{
			vis[i] = true ;
			if(pre[i] == -1 || find(pre[i]))
			{
				pre[i] = pos ;
				return 1 ;
			}
		}
	}
	return 0 ;
}

int main()
{
	int t ;
	scanf("%d",&t) ;
	while(t--)
	{
		scanf("%d%d",&p,&n) ;
		memset(map,false,sizeof(map)) ;
		memset(pre,-1,sizeof(pre)) ;
		for(int i = 1 ; i <= p ; ++i)
		{
			int j ;
			scanf("%d",&j);
			while(j--)
			{
				int c ;
				scanf("%d",&c);
				map[i][c] = true ;
			}
		}
		int cnt = 0 ;
		for(int i = 1 ; i <= p ; ++i)
		{
			memset(vis,false,sizeof(vis)) ;
			cnt += find(i) ;
		}
		if(cnt==p)
			puts("YES") ;
		else
			puts("NO") ;
	}
	return 0 ;
}
与君共勉

hdu Courses 1083 二分匹配 ,匈牙利算法。。水题

标签:hdu1083   dfs   二分匹配   

原文地址:http://blog.csdn.net/lionel_d/article/details/45331061

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!