码迷,mamicode.com
首页 > Web开发 > 详细

ZOJ 3819 Average Score(数学 牡丹江游戏网站)

时间:2015-06-18 15:09:21      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

主题链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5373


Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob‘s. Please calculate the possible range of Bob‘s score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob‘s class and the number of students in the other class respectively.

The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob‘s class.

The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2 4

Author: JIANG, Kai


PS:2014年ACM/ICPC 亚洲区域赛牡丹江(第一站)___签到题!


代码例如以下:

#include <cstdio>
#include <cmath>
int main()
{

    int t;
    int n, m;
    int minn, maxx;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        double sum1=0, sum2=0;
        int a;
        for(int i = 0; i < n-1; i++)
        {
            scanf("%d",&a);
            sum1+=a;
        }
        for(int i = 0; i < m; i++)
        {
            scanf("%d",&a);
            sum2+=a;
        }
        double avg1=(sum1/(n-1.0));
        double avg2=sum2/(m*1.0);
        if((int)avg1==avg1)
            maxx=(int)avg1-1;
        else
            maxx=(int)avg1;
        minn=(int)avg2+1;
        printf("%d %d\n",minn,maxx);
    }
    return 0;
}


ZOJ 3819 Average Score(数学 牡丹江游戏网站)

标签:

原文地址:http://www.cnblogs.com/gcczhongduan/p/4585851.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!