码迷,mamicode.com
首页 > 其他好文 > 详细

lightoj 1079 Just another Robbery 解题心得

时间:2015-08-21 21:02:58      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:

原题:

Description

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability Pof getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

 

 

分析:状态题,01背包,用二维转态表示三个量。

 dp[i][j] = min(dp[i-1][j] , dp[i-1][j-v[i]]) ,dp[i][j]表示前 i 个银行抢劫到 j 这么多钱被抓的概率。

 

代码:

#include<stdio.h>
#define maxn 110
#define min(a,b) (a)>(b)?(b):(a)

double a[maxn];
int v[maxn];
double f[maxn][maxn*maxn];
int main()
{
    int T, cas = 1;
    int n;
    double p;
    int sum;
    scanf("%d", &T);
    while (T--)
    {
        sum = 0;
        scanf("%lf%d", &p, &n);
        for (int i = 1; i <= n; i++)   
            scanf("%d%lf", &v[i], &a[i]), sum += v[i];
        for (int i = 1; i <= sum; i++)   
            f[0][i] = -1;
        f[0][0] = 0;
        for (int i = 1; i <= n; i++)
            for (int j = 0; j <= sum; j++)
            {
                if (j - v[i]<0 || f[i - 1][j - v[i]]<-0.5)  
                    f[i][j] = f[i - 1][j];
                else 
                    if(f[i - 1][j]<0)  
                        f[i][j] = f[i - 1][j - v[i]] + (1 - f[i - 1][j - v[i]])*a[i];
                    else
                        f[i][j] = min(f[i - 1][j], f[i - 1][j - v[i]] + (1 - f[i - 1][j - v[i]])*a[i]);
            }
        int ans = 0;
        for (int i = 0; i <= sum; i++)
            if (f[n][i]>-0.5 && f[n][i]<p)
                ans = i;
        printf("Case %d: %d\n", cas++, ans);
    }
    return 0;
}

 

 

lightoj 1079 Just another Robbery 解题心得

标签:

原文地址:http://www.cnblogs.com/shawn-ji/p/4748939.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!