码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2602 01背包Bone Collector

时间:2015-08-26 17:52:28      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 40316    Accepted Submission(s): 16748


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct stu {
	int val;
	int cos;
}boy[10010];
//stu ;
//int bag[10010];
int nexty[10010];//如果把所有nexty都改为next提交时出现编译错误。
int main()
{
	int n;
	int a,b;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&a,&b);
		memset(boy,0,sizeof(boy));
	//	memset(bag,0,sizeof(bag));
		memset(nexty,0,sizeof(nexty));
		for(int i=0;i<a;i++)
		   scanf("%d",&boy[i].val);
		for(int j=0;j<a;j++)
		   scanf("%d",&boy[j].cos);
		for(int i=0;i<a;i++)
		{
			for(int j=b;j>=boy[i].cos;j--)
		//	bag[j]=max(bag[j],bag[j-boy[i].cos]+boy[i].val);
			nexty[j]=max(nexty[j],nexty[j-boy[i].cos]+boy[i].val);
		}
		//printf("%d\n",bag[b]);
		printf("%d\n",nexty[b]);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu2602 01背包Bone Collector

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/48006469

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!