码迷,mamicode.com
首页 > 其他好文 > 详细

杭电(hdu)2070 Fibbonacci Number 水题

时间:2015-08-27 13:37:33      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:fibbonacci number   水题   

Fibbonacci Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17675    Accepted Submission(s): 8422


Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.
 

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
 

Output
Print out the answer in a single line for each test case.
 

Sample Input
3 4 5 -1
 

Sample Output
2 3 5
这是一道编程最基础最基础入门的题目了,在ACM上面的话讲就是水题,我们采用外围打表法,可以降低时间复杂度。
代码如下:
#include <iostream>
#include <cstring>
using namespace std;

long long a[51];
void initial()
{
	a[0]=0;
	a[1]=1;
	for(int i=2;i<=50;i++)
	{
		a[i]=a[i-1]+a[i-2];
	}
}

int main()
{
	int n;
	initial();
	while(cin>>n&&n!=-1)
	{
		cout<<a[n]<<endl;
	}
	return 0;
} 


版权声明:本文为博主原创文章,未经博主允许不得转载。欢迎读者评论和指正

杭电(hdu)2070 Fibbonacci Number 水题

标签:fibbonacci number   水题   

原文地址:http://blog.csdn.net/it142546355/article/details/48024101

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!