码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3264 Balanced Lineup(线段数求区间最大最小值)

时间:2014-07-13 19:35:19      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   strong   

链接:http://poj.org/problem?id=3264

 

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 32772   Accepted: 15421
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0


=====================================================================
思路也很清晰,就是重新弄一个root[]数组求最小值,开始把minn设为0,找了好久才找到

bubuko.com,布布扣
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>

using namespace std;
#define Maxx 50010
int str[Maxx],root[Maxx<<2],root1[Maxx<<2];
int n;
int minn,maxx;

void make_tree(int l,int r,int rt)
{
    if(l == r)
    {
        root[rt]=str[l];
        root1[rt]=str[l];
        return ;
    }

    int mid=(l+r)/2;
    make_tree(l,mid,rt*2);
    make_tree(mid+1,r,rt*2+1);
    root[rt]=max(root[rt*2],root[rt*2+1]);
    root1[rt]=min(root1[rt*2],root1[rt*2+1]);
}

void update(int l,int r,int rt,int a,int b)
{
    if(l == r && l == a)
    {
        root[rt]=b;
        root1[rt]=b;
        return ;
    }

    int mid=(l+r)/2;
    if(a<=mid)
        update(l,mid,rt*2,a,b);
    else
        update(mid+1,r,rt*2+1,a,b);

    root[rt]=max(root[rt*2],root[rt*2+1]);
    root1[rt]=min(root1[rt*2],root1[rt*2+1]);
}

void query(int l,int r,int rt,int left,int right)
{
    if(l == left&&r == right)
    {
        maxx=max(maxx,root[rt]);
        minn=min(minn,root1[rt]);
        return ;
    }

    int mid=(l+r)/2;
    if(left>mid)
    {
        query(mid+1,r,rt*2+1,left,right);
    }
    else if(right<=mid)
    {
        query(l,mid,rt*2,left,right);
    }
    else
    {
        query(l,mid,rt*2,left,mid);
        query(mid+1,r,rt*2+1,mid+1,right);
    }
}

int main()
{
    int q;
    int i,j;
    int a,b;
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&str[i]);
        }
        make_tree(1,n,1);
        for(i=1;i<=q;i++)
        {
            minn=100000000;maxx=0;
            scanf("%d%d",&a,&b);
            query(1,n,1,a,b);
            printf("%d\n",maxx-minn);
        }
    }
    return 0;
}
View Code

 

poj 3264 Balanced Lineup(线段数求区间最大最小值),布布扣,bubuko.com

poj 3264 Balanced Lineup(线段数求区间最大最小值)

标签:des   style   blog   http   color   strong   

原文地址:http://www.cnblogs.com/ccccnzb/p/3841135.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!