码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 927 The partial sum problem

时间:2014-07-16 19:24:53      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   os   art   for   

The partial sum problem

时间限制:1000 ms  |            内存限制:65535 KB
难度:2
 
描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 
 
输入
There are multiple test cases. Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!
Sorry,I can‘t!


#include <stdio.h>
int e[25];
int imt;
int num;

int dfs(int step,int count)//深度搜索 这里还用到了动态规划的思想 01背包问题
{
    if(step==num)
        return count==imt;
    if(dfs(step+1,count))
        return 1;
    if(dfs(step+1,count+e[step]))
        return 1;
    return 0;
}

int main()
{

    int i,j,k;
    
    while(scanf("%d",&num)!=EOF)
    {
        for(i=0;i<num;i++)
        {
            scanf("%d",e+i);
        }
        scanf("%d",&imt);
        
        if(dfs(0,0))
            printf("Of course,I can!\n");
        else
            printf("Sorry,I can‘t!\n");
    }
    
    return 0;
}


刚开始写的时候一直超时,很郁闷,搜索了下,发现用深搜加上动态规划的思想便可以解决~,很棒的一种方法~

nyoj 927 The partial sum problem,布布扣,bubuko.com

nyoj 927 The partial sum problem

标签:style   blog   color   os   art   for   

原文地址:http://www.cnblogs.com/ltwy/p/3841278.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!