码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2199 Can you solve this equation?(高精度二分)

时间:2015-09-03 23:22:17      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/howproblem.php?pid=2199

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13468    Accepted Submission(s): 6006


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

 

Sample Input
2
100
-4
 

 

Sample Output
1.6152
No solution!
 
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define N 100010

using namespace std;

int main()
{
    int t, y;
    double low, high, mid, k, x1, x2;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &y);
        low = 0;
        high = 100;
        x1 = 8 * pow(0, 4) + 7 * pow(0, 3) + 2 * pow(0, 2) + 3 * 0 + 6;
        x2 = 8 * pow(100, 4) + 7 * pow(100, 3) + 2 * pow(100, 2) + 3 * 100 + 6;
        if(x1 <= y && y <= x2)
        {
            while(high - low > 1e-7)/*注意1e-7*/
            {
                mid = (low + high) / 2;
                k = 8 * pow(mid, 4) + 7 * pow(mid, 3) + 2 * pow(mid, 2) + 3 * mid + 6;
                if(k > y)
                    high = mid - 1e-7;
                else if(k < y)
                    low = mid + 1e-7;
            }
            printf("%.4f\n", 1.0 * (low + high) / 2);
        }
        else
            printf("No solution!\n");

    }
    return 0;
}

 

 

 

hdu 2199 Can you solve this equation?(高精度二分)

标签:

原文地址:http://www.cnblogs.com/qq2424260747/p/4780862.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!