码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1102 Constructing Roads

时间:2015-09-08 19:59:47      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=1102  

Constructing Roads

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

最小生成树。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<map>
using std::map;
using std::min;
using std::find;
using std::pair;
using std::vector;
using std::multimap;
using std::priority_queue;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 110;
const int INF = 0x3f3f3f3f;
struct P {
    int w, v;
    P(int i = 0, int j = 0) :w(i), v(j) {}
    inline bool operator<(const P &x) const {
        return w > x.w;
    }
};
struct Prim {
    struct edge { int to, w, next; }G[(N * N) << 1];
    bool vis[N];
    int tot, head[N], mincost[N];
    inline void init() {
        tot = 0, cls(vis, false), cls(head, -1), cls(mincost, 0x3f);
    }
    inline void add_edge(int u, int v, int w) {
        G[tot] = (edge){ v, w, head[u] }; head[u] = tot++;
    }
    inline void fix_up(int u, int v) {
        for(int i = head[u]; ~i; i = G[i].next) {
            if(G[i].to == v) {
                G[i].w = 0;
                return;
            }
        }
    }
    inline void built(int V) {
        int u, v, q;
        rep(i, V) {
            rep(j, V) {
                scanf("%d", &v);
                if(i == j) continue;
                add_edge(i + 1, j + 1, v);
            }
        }
        scanf("%d", &q);
        while(q--) {
            scanf("%d %d", &u, &v);
            fix_up(u, v), fix_up(v, u);
        }
    }
    inline void prim(int s) {
        int ans = 0;
        priority_queue<P> q;
        q.push(P(0, s));
        for(int i = head[s]; ~i; i = G[i].next) {
            mincost[G[i].to] = G[i].w;
            q.push(P(G[i].w, G[i].to));
        }
        vis[s] = true;
        while(!q.empty()) {
            P t = q.top(); q.pop();
            int u = t.v;
            if(vis[u]) continue;
            vis[u] = true;
            ans += mincost[u];
            for(int i = head[u]; ~i; i = G[i].next) {
                int &d = mincost[G[i].to];
                if(d > G[i].w && !vis[G[i].to]) {
                    d = G[i].w;
                    q.push(P(d, G[i].to));
                }
            }
        }
        printf("%d\n", ans);
    }
    inline void solve(int V) {
        init(), built(V), prim(1);
    }
}go;
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    int V;
    while(~scanf("%d", &V)) {
        go.solve(V);
    }
    return 0;
}

hdu 1102 Constructing Roads

标签:

原文地址:http://www.cnblogs.com/GadyPu/p/4792692.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!