码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3371 Connect the Cities

时间:2015-09-08 21:53:23      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=3371  

Connect the Cities

Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money. 

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output

1

最小生成树,这道题卡时间g++过了,c++ tle了/(ㄒoㄒ)/~~。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<map>
using std::map;
using std::min;
using std::sort;
using std::pair;
using std::vector;
using std::multimap;
using std::priority_queue;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) decltype((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 510;
const int INF = 0x3f3f3f3f;
struct edge {
    int u, v, w;
    inline bool operator<(const edge &x) const {
        return w < x.w;
    }
}G[(N * N) << 1];
struct Kruskal {
    int E, par[N], rank[N];
    inline void init(int n) {
        E = 0;
        rep(i, n + 2) {
             par[i] = i;
             rank[i] = 0;
        }
    }
    inline int find(int x) {
        while(x != par[x]) {
            x = par[x] = par[par[x]];
        }
        return x;
    }
    inline bool unite(int x, int y) {
        x = find(x), y = find(y);
        if(x == y) return false;
        if(rank[x] < rank[y]) {
            par[x] = y;
        } else {
            par[y] = x;
            rank[x] += rank[x] == rank[y];
        }
        return true;
    }
    inline void built(int m, int k) {
        int u, v, w, q, fa;
        while(m--) {
            scanf("%d %d %d", &u, &v, &w);
            G[E++] = { u, v, w };
        }
        while(k--) {
            scanf("%d", &q);
            scanf("%d %d", &u, &v);
            G[E++] = { u, v, 0 };
            fa = v;
            rep(i, q - 2) {
                scanf("%d", &v);
                G[E++] = { fa, v, 0 };
                fa = v;
            }
        }
    }
    inline int kruskal(int n) {
        int ans = 0, cnt = 0;
        sort(G, G + E);
        rep(i, E) {
            int u = G[i].u, v = G[i].v;
            if(unite(u, v)) {
                ans += G[i].w;
                if(++cnt >= n - 1) return ans;
            }
        }
        return -1;
    }
    inline void solve(int n, int m, int k) {
        init(n), built(m, k);
        printf("%d\n", kruskal(n));
    }
}go;
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    int n, m, k, T;
    scanf("%d", &T);
    while(T--) {
        scanf("%d %d %d", &n, &m, &k);
        go.solve(n, m, k);
    }
    return 0;
}

hdu 3371 Connect the Cities

标签:

原文地址:http://www.cnblogs.com/GadyPu/p/4792917.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!