码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2846 Repository

时间:2015-09-08 22:01:59      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=2846  

Repository

Description

When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.

Input

There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it‘s length isn‘t beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.

Output

For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

Sample Input

20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s

Sample Output

0
20
11
11
2

字典树,g++ mle c++ ac。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<set>
using std::set;
using std::min;
using std::find;
using std::pair;
using std::vector;
using std::multiset;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 100010;
const int INF = 0x3f3f3f3f;
struct Node {
	Node *ch[26];
	int cnt;
	int f;
	Node() {
		rep(i, 26) ch[i] = NULL;
		cnt = 0;
		f = -1;
	}
}*root;
void insert(Node *x, char *str, int f) {
	int d = 0;
	char *p = str;
	while (*p != ‘\0‘) {
		d = *p - ‘a‘;
		if (!x->ch[d]) x->ch[d] = new Node();
		x = x->ch[d];
		if (x->f != f) {
			x->f = f;
			x->cnt++;
		}
		p++;
	}
}
int query(Node *x, char *str) {
	char *p = str;
	while (*p != ‘\0‘) {
		if (!x || !x->ch[*p - ‘a‘]) return 0;
		x = x->ch[*p - ‘a‘];
		p++;
	}
	return x->cnt;
}
void built(int t) {
	int n;
	char buf[100];
	rep(i, t) {
		scanf("%s", buf);
		n = strlen(buf);
		rep(j, n) {
			insert(root, buf + j, i);
		}
	}
}
void solve(int n) {
	int m;
	char buf[100];
	root = new Node();
	built(n);
	scanf("%d", &m);
	while (m--) {
		scanf("%s", buf);
		printf("%d\n", query(root, buf));
	}
}
int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w+", stdout);
#endif
	int n;
	while (~scanf("%d", &n)) {
		solve(n);
	}
	return 0;
}

hdu 2846 Repository

标签:

原文地址:http://www.cnblogs.com/GadyPu/p/4792900.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!