码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1528 (二分图最大匹配 + 最小覆盖, 14.07.17)

时间:2014-07-17 20:17:43      阅读:381      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   art   io   

Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

 

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
 

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 

Sample Input
3 1 JD JH 2 5D TC 4C 5H 3 2H 3H 4H 2D 3D 4D
 

Sample Output
1 1 2
 

题意:田忌赛马的意思,对方的牌摆在你面前了,你用你手中的牌去击败他们,规则是点数大的赢点数小的,点数相同就比花色。问:最多能打败对方几张牌?

做法:二分图匹配的题目,建图,套公式即可,关键点就是建一个map图时,要满足eve的牌大于adam的牌时才能建立可匹配的一条路,否则不建路,赋值为0。

坑点:A是最大的点数!

看AC代码:

#include<stdio.h>
#include<string.h>

int k, t;
int map[52][52];
int vis[52];
int has[52];

const char pai[52][3] = {
	"2C", "2D", "2S", "2H",
	"3C", "3D", "3S", "3H",
	"4C", "4D", "4S", "4H",
	"5C", "5D", "5S", "5H",
	"6C", "6D", "6S", "6H",
	"7C", "7D", "7S", "7H",
	"8C", "8D", "8S", "8H",
	"9C", "9D", "9S", "9H",
	"TC", "TD", "TS", "TH",
	"JC", "JD", "JS", "JH",
	"QC", "QD", "QS", "QH",
	"KC", "KD", "KS", "KH",
	"AC", "AD", "AS", "AH"};

int getNum(char *str) {
	for(int i = 0; i < 52; i++) {
		if(strcmp(pai[i], str) == 0)
			return i;
	}
	return -1;
}

int find(int a) {
	for(int i = 0; i < 52; i++) {
		if(map[a][i] && vis[i] == 0) {
			vis[i] = 1;
			if(has[i] == -1 || find(has[i])) {
				has[i] = a;
				return 1;
			}
		}
	}
	return 0;
}

int main() {
	scanf("%d", &t);
	while(t--) {
		scanf("%d", &k);

		char adam[26][3];
		char eve[26][3];

		for(int i = 0; i < k; i++)
			scanf("%s", adam[i]);
		for(int i = 0; i < k; i++)
			scanf("%s", eve[i]);

		memset(map, 0, sizeof(map));

		for(int i = 0; i < k; i++) {
			for(int j = 0; j < k; j++) {
				int p1 = getNum(adam[i]);
				int p2 = getNum(eve[j]);
				if(p1 < p2)
					map[p1][p2] = 1;
			}
		}

		memset(has, -1, sizeof(has));

		int sum = 0;
		for(int i = 0; i < 52; i++) {
			memset(vis, 0, sizeof(vis));
			sum += find(i);
		}
		printf("%d\n", sum);
	}
}


HDU 1528 (二分图最大匹配 + 最小覆盖, 14.07.17),布布扣,bubuko.com

HDU 1528 (二分图最大匹配 + 最小覆盖, 14.07.17)

标签:des   style   color   os   art   io   

原文地址:http://blog.csdn.net/qq297060023/article/details/37909817

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!