码迷,mamicode.com
首页 > 其他好文 > 详细

01背包

时间:2014-07-18 15:11:55      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   2014   

<span style="color:#3333ff;">/*
__________________________________________________________________________________________________
*     copyright:   Grant Yuan                                                                     *
*     algorithm:   01背包                                                                       *
*     time     :   2014.7.18                                                                      *
*_________________________________________________________________________________________________*
F - 01背包
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 


 
Input
The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 
Sample Input
 1
5 10
1 2 3 4 5
5 4 3 2 1 
 
Sample Output
 14 
 */
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<functional>
#include<queue>
#include<stack>
#include<cstdlib>
using namespace std;

int v[1001];
int p[1001];
int n,sv,t;
int dp[2][1001];

int main()
{
	cin>>t;
	while(t--){
	  cin>>n>>sv;
	  for(int i=0;i<n;i++)
		  cin>>p[i];
	  for(int i=0;i<n;i++)
		  cin>>v[i];
	  memset(dp,0,sizeof(dp));
	  for(int i=0;i<n;i++)
		 for(int j=0;j<=sv;j++)
	  {
	  	if(j<v[i])
			  dp[(i+1)&1][j]=dp[i&1][j];
	    else
			  dp[(i+1)&1][j]=max(dp[i&1][j],dp[i&1][j-v[i]]+p[i]);

	  }
	  cout<<dp[n&1][sv]<<endl;
	}
	return 0;
}
</span>

01背包,布布扣,bubuko.com

01背包

标签:des   style   blog   color   os   2014   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/37927565

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!