码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3336(KMP + dp)

时间:2015-11-12 17:30:16      阅读:301      评论:0      收藏:0      [点我收藏+]

标签:

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6875    Accepted Submission(s): 3191

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 
Sample Input
1
4
abab
 
Sample Output
6
 
Author
foreverlin@HNU
 
Source
 
题意:求给定字符串含前缀的数量
dp[i] 表示子串[1~i]含有以string[i]为结尾的前缀的种类数
/*
ID: LinKArftc
PROG: 3336.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const double e = exp(1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

const int maxn = 200010;
const int MOD = 10007;
int dp[maxn];
char str[maxn];
int Next[maxn];

void getNext(char *p) {
    int i = 0, j = -1;
    int len = strlen(p);
    Next[0] = -1;
    while (i < len) {
        if (j == -1 || p[i] == p[j]) {
            i ++; j ++;
            Next[i] = j;
        } else j = Next[j];
    }
}

int main() {
    int T, n;
    scanf("%d", &T);
    while (T --) {
        scanf("%d", &n);
        scanf("%s", str);
        getNext(str);
        dp[0] = 0;
        int ans = 0;
        for (int i = 1; i <= n; i ++) {
            dp[i] = (dp[Next[i]] + 1) % MOD;
            ans = (dp[i] + ans) % MOD;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

HDU3336(KMP + dp)

标签:

原文地址:http://www.cnblogs.com/LinKArftc/p/4959434.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!