码迷,mamicode.com
首页 > 其他好文 > 详细

poj1655 Balancing Act(树形dp)

时间:2015-11-27 15:03:29      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

Balancing Act
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11176   Accepted: 4702

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 
技术分享

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source


题意:给定一颗n个节点的树,求删除一个节点后所剩的所有子树中节点数最多的节点最少。(表达不是很好,其实就和poj3107一样的)
分析:和poj3107一样的,就只要改下输入输出就可以了,poj3107

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 40010

struct node
{
    int v;
    node *next;
}tree[MAXN], *head[MAXN];
int n,pre,dp[MAXN];
int ans,num,tot;

void init()
{
    ans = INF;
    pre = 1;
    CL(dp, 0);
    CL(head, NULL);
}

void add(int x, int y)
{
    tree[pre].v = y;
    tree[pre].next = head[x]; head[x] = &tree[pre++];
    tree[pre].v = x;
    tree[pre].next = head[y]; head[y] = &tree[pre++];
}

void dfs(int son, int father)
{
    node *p = head[son];
    dp[son] = 1;
    while(p != NULL)
    {
        if(p->v != father)
        {
            dfs(p->v, son);
            dp[son] += dp[p->v];
        }
        p = p->next;
    }
}

void dp_tree(int son, int father)
{
    int maxx = 0;
    node *p = head[son];
    while(p != NULL)
    {
        if(p->v != father)
        {
            dp_tree(p->v, son);
            maxx = max(maxx, dp[p->v]);
        }
        p = p->next;
    }
    maxx = max(maxx, n-dp[son]);
    if(maxx < ans)//对比poj3107,也就改下这里,只把最小的保存下来就行了
    {
        ans = maxx;
        num = son;
    }
    else if(maxx == ans)
    {
        if(num > son) num = son;
    }
}

int main()
{
    int T,a,b;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        init();
        for(int i=1; i<n; i++)
        {
            scanf("%d%d",&a,&b);
            add(a, b);
        }
        dfs(1, 0);
        dp_tree(1, 0);
        printf("%d %d\n",num, ans);
    }
    return 0;
}


poj1655 Balancing Act(树形dp)

标签:

原文地址:http://blog.csdn.net/d_x_d/article/details/50068571

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!