码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3080 Blue Jeans

时间:2014-07-20 23:18:45      阅读:286      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   strong   os   

表示今天下午ac了一道放置几天的问题,开心=。=

Blue Jeans
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11795   Accepted: 5099

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	int nn,cc;
	cin>>nn;
	for(cc=1;cc<=nn;cc++)
	{
		int n;
		cin>>n;
		char a[20][65];
		int i,j;
		for(i=0;i<n;i++)
			cin>>a[i];
		char str[65];
		char s[65];
		int sum=0,max=0;
		int len=0;
		int maxlen=0;
		for(i=0;i<61;i++)
		{
			for(j=i+3;j<61;j++)
			{
				int k;
				bool flag=1;
				int m1=i;
				for(k=0;k<j-i;k++)
				{
					str[k]=a[0][m1];
					m1++;
					if(m1==j)
						break;
				}
				str[k+1]='\0';
				int m;
				for( m=1;m<n;m++)
					if(strstr(a[m],str)==NULL)
						flag=0;
					if(flag)
					{
						len=j-i; 
						if(len>maxlen)
						{
							maxlen=len;
							strcpy(s,str);
						}
						else if(len==maxlen)  
						{  
							if(strcmp(s,str)>0)  //存在相同长度的公共串时,取最小字典序的串  
								strcpy(s,str);  
						}  
					}
					
			}
		}
		if(maxlen<3)
			cout<<"no significant commonalities"<<endl;
		else
			cout<<s<<endl;
	}
	
	return 0;
}


/*
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
*/
/*
2
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
2
GATGATGCATCATGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGACTACTAA
GATGATCATCATACTACTCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
*/


POJ 3080 Blue Jeans,布布扣,bubuko.com

POJ 3080 Blue Jeans

标签:des   style   blog   color   strong   os   

原文地址:http://blog.csdn.net/sunshumin/article/details/37992085

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!