码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1011

时间:2015-12-12 20:19:18      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:

1011. World Cup Betting (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner‘s odd would be the product of the three odds times 65%.

For example, 3 games‘ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98

解析:题目很简单,但是sample给的略坑,其实后面的输出应该是37.97,题目有一点误导。

Code:
/*************************************************************************
    > File Name: 1011.cpp
    > Author: 
    > Mail: 
    > Created Time: 2015年12月12日 星期六 19时30分41秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
using namespace std;

float findmax(float a, float b, float c, char &value){
    if(a > b){
        if(a > c){
            value = W;
            return a;
        }
        else{
            value = L;
            return c;
        }
    }
    else{
        if(b > c){
            value = T;
            return b;
        }
        else{
            value = L;
            return c;
        }
    }
}

int main(){

    float w1,t1,l1;
    float w2,t2,l2;
    float w3,t3,l3;
    cin>>w1>>t1>>l1;
    cin>>w2>>t2>>l2;
    cin>>w3>>t3>>l3;

    char choice1,choice2,choice3;
    float a = findmax(w1,t1,l1,choice1);
    float b = findmax(w2,t2,l2,choice2);
    float c = findmax(w3,t3,l3,choice3);

    float result = (a*b*c*0.65-1.0)*2;
    //printf("%f*%f*%f*0.65-1.0 * 2=%f\n",a,b,c,result);
    printf("%c %c %c %.2f",choice1,choice2,choice3,result);
    return 0;
}

 

 

PAT 1011

标签:

原文地址:http://www.cnblogs.com/RookieCoder/p/5041709.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!