码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1097 A hard puzzle

时间:2014-07-23 13:23:26      阅读:282      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   os   strong   

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28758    Accepted Submission(s): 10283


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b‘s last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6
 



#include<stdio.h>
int main()
{
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		int i,last;
		a=a%10;
		b=b%4;
		last=a;//必须在此处将a的值赋给last
		if(b==0)  b=4; 
		for(i=1;i<b;i++)
		{
			last=a*last%10;
		}
		printf("%d\n",last);
	}
	return 0;
}


HDU 1097 A hard puzzle,布布扣,bubuko.com

HDU 1097 A hard puzzle

标签:des   style   java   color   os   strong   

原文地址:http://blog.csdn.net/qq_16767427/article/details/38058135

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!