码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 4864 Task 【贪心】

时间:2014-07-23 13:25:18      阅读:297      评论:0      收藏:0      [点我收藏+]

标签:贪心

贪心策略:因为2*难度(1~100) 远比500*时间 的影响小,所以说,先对时间从大到小排序,相等的再按照等级从大到小排序;对任务和机器都排序之后,再统计满足任务时间的机器,选择等级最接近任务难度的的机器;

因为数据很多,很可能超出int范围,要用长整型,但是最后输出的时候,如果用printf( "%lld %lld\n", sol, sum );输出的话,会发现第二个数会是0,在这上面wa了n次。。

最后问了一下学长,用了%I64,才正确,后来有自己百度了一下http://blog.csdn.net/shiwei408/article/details/7463476写的很好,我就不多说了

 

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1273    Accepted Submission(s): 313


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
1 2 100 3 100 2 100 1
 

Sample Output
1 50004
 

Author
FZU
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
typedef struct{
	int time, lev;
}str;
str mac[100015], tas[100015];
int d[111];

int cmp( str a, str b )
{
	if( a.time == b.time ) return a.lev > b.lev;
	return a.time>b.time;
}
int main()
{
	int n, m, i, j;
	while( scanf( "%d%d", &n, &m ) != EOF ){
		long long sum = 0;
		long long sol = 0;
		memset( d, 0, sizeof(d) );
		memset( tas, 0, sizeof(tas) );
		memset( mac, 0, sizeof(mac) );
		for( i = 0; i < n; i ++ )
		scanf( "%d%d", &mac[i].time, &mac[i].lev );
		for( i = 0; i < m; i ++ )
		scanf( "%d%d", &tas[i].time, &tas[i].lev );
		sort( tas, tas+m, cmp );
		sort( mac, mac+n, cmp );
		for( i =0, j = 0; i < m; i ++ ){
			while( j < n&&mac[j].time>=tas[i].time ){
				d[mac[j].lev]++;
				++j;
			}
			for( int k = tas[i].lev; k <= 100; k ++ ){
				if( d[k] ){
					++sol;
					sum += 500*tas[i].time+2*tas[i].lev;
					--d[k];
					break;
				}
			}
		} 
		printf( "%I64d %I64d\n", sol, sum );
		//cout<<sol<<' '<<sum<<endl; //也可以用这种方法
	}
	return 0;
}

hdoj 4864 Task 【贪心】

标签:贪心

原文地址:http://blog.csdn.net/shengweisong/article/details/38057847

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!