码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2141 Message Decowding(map)

时间:2014-07-24 17:45:06      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   strong   io   width   for   

Message Decowding
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11735   Accepted: 6536

Description

The cows are thrilled because they‘ve just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms. 

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher. 

The cows have a decryption key and a secret message. Help them decode it. The key looks like this: 
        yrwhsoujgcxqbativndfezmlpk

Which means that an ‘a‘ in the secret message really means ‘y‘; a ‘b‘ in the secret message really means ‘r‘; a ‘c‘ decrypts to ‘w‘; and so on. Blanks are not encrypted; they are simply kept in place. 

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course. 

Input

* Line 1: 26 lower case characters representing the decryption key 

* Line 2: As many as 80 characters that are the message to be decoded 

Output

* Line 1: A single line that is the decoded message. It should have the same length as the second line of input. 

Sample Input

eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj

Sample Output

Jump the fence when you seeing me coming


#include<iostream>
#include<stdio.h>
#include<cstring>
#include<map>
using namespace std;
int main()
{
    map <char,char> record;
    map<char, char >::iterator  it;
    char str1[26],str2[101];
    int i;
    for(i=0;i<26;i++)
    {
        cin>>str1[i];
        record[i+'a']=str1[i];
    }
    getchar();
    gets(str2);
    int len;
    len=strlen(str2);

    for(i=0;i<len;i++)
    {
        if(str2[i]==' ')
        {
            cout<<" ";
            continue;
        }
        else if(str2[i]>='A'&&str2[i]<='Z')
        {
            it=record.find(str2[i]+32);
            cout<<char(it->second-32);
        }
        else
        {
            it=record.find(str2[i]);
            cout<<it->second;
        }
    }
	cout<<endl;
    return 0;
}




POJ 2141 Message Decowding(map),布布扣,bubuko.com

POJ 2141 Message Decowding(map)

标签:des   style   color   os   strong   io   width   for   

原文地址:http://blog.csdn.net/sunshumin/article/details/38083623

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!