码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3624(01背包:滚动 实现)

时间:2016-02-09 11:15:03      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30417   Accepted: 13576

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
#include"cstdio"
#include"cstring"
#include"algorithm"
using namespace std;
const int MAXN=3405;
int dp[13000];
int n,W;
int v[MAXN],w[MAXN];
int main()
{
    while(scanf("%d%d",&n,&W)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)    scanf("%d%d",&w[i],&v[i]);
        
        for(int i=0;i<n;i++)
        {
            for(int j=W;j>=w[i];j--)    dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        }
        printf("%d\n",dp[W]);
    }
    
    return 0;
}

 

POJ3624(01背包:滚动 实现)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5185452.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!