码迷,mamicode.com
首页 > 其他好文 > 详细

[2016-02-19][UVA][129][Krypton Factor]

时间:2016-02-19 23:13:44      阅读:518      评论:0      收藏:0      [点我收藏+]

标签:

[2016-02-19][UVA][129][Krypton Factor]
UVA - 129
Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

 Status

Description

技术分享

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy‘‘. Other sequences will be called ``hard‘‘.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

  • BB
  • ABCDACABCAB
  • ABCDABCD

Some examples of hard sequences are:

  • D
  • DC
  • ABDAB
  • CBABCBA

Input and Output

In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range 技术分享 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:


AB 
ABA 
ABAC 
ABACA 
ABACAB 
ABACABA

As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7

Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input

30 3
0 0

Sample Output

ABAC ABCA CBAB CABA CABC ACBA CABA
28





#define _WORK_
#ifdef _WORK_
/*************************************************************
时间:2016-02-19 22:13:47 星期五
题目编号:UVA 129
题目大意:给定数字n 和L,输出由前l个字母组成,字典序第n小的hard串
        hard串:没有重复的相邻子串
分析:dfs枚举所有答案,不断增加字母,每增加一个字母,检查字符串是否有效,直到生成到第n个有效的串
*************************************************************/
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;
#define CLR(x,y) memset((x),(y),sizeof((x)))
const int maxl = 80;
char res[maxl];
int n,l,cnt;
int check(int len){//检查增加一个字符后,是否有效
        for(int i = 1; i <= len / 2;++i){
                int flg = 0;
                for(int j = 1;!flg && j <= i; ++j){
                        if( res[len - i - j] != res[len - j] )
                                flg = 1;
                }
                if(!flg)        return 0;
        }
        return 1;
}

int dfs(int cur){
        if(!cur || check(cur)){
                if(++cnt == n){
                        for(int i = 0; i < cur ;++i){
                                putchar(res[i]);
                                if(((i+1) % (4 * 16) == 0 )|| i + 1 == cur) putchar(‘\n‘);
                                else if((i+1) % 4 == 0)  putchar(‘ ‘);
                        }
                        printf("%d\n",cur);
                        return 1;
                }else {
                        for(int i = 0; i < l ;++i){
                                res[cur] = ‘A‘ + i;//cur位置,依次增加前 l 个字符
                                if(dfs(cur + 1))        return 1;     
                        }
                }
        }
        return 0;
}
        
int main(){
        while(~scanf("%d%d",&n,&l) && (l || n)){
                cnt = -1;
                dfs(0);
        }
    return 0;
}
#endif  




[2016-02-19][UVA][129][Krypton Factor]

标签:

原文地址:http://www.cnblogs.com/qhy285571052/p/5202434.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!