码迷,mamicode.com
首页 > 其他好文 > 详细

Elevator

时间:2016-02-26 22:08:41      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59259    Accepted Submission(s): 32539

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 
Output
Print the total time on a single line for each test case. 
 
Sample Input
1 2 3 2 3 1 0
 
Sample Output
17 41

 

这题比较简单,下面是我做的答案:

 

#include<iostream>

using namespace std;

 

int main()
{
int count=0;//几个数
while(cin>>count)
{
if(count==0) break;
int sum=0;
int before=0;
int now=0;
while(count--)
{
cin>>now;
if(now>before)
{
sum+=(now-before)*6+5;
}
else
{
sum+=(before-now)*4+5;
}
before=now;
}
cout<<sum<<endl;
}
return 0;
}

 

Elevator

标签:

原文地址:http://www.cnblogs.com/honeybusybee/p/5221850.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!