码迷,mamicode.com
首页 > 其他好文 > 详细

[2016-03-03][UVA][120][Stacks of Flapjacks]

时间:2016-03-04 22:35:48      阅读:331      评论:0      收藏:0      [点我收藏+]

标签:

[2016-03-03][UVA][120][Stacks of Flapjacks]


UVA - 120
Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

 Status

Description

技术分享

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake‘s diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips‘‘. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7
The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

  • 时间:2016-03-03 19:28:52 星期四
  • 题目编号:UVA 120
  • 题目大意:
    •     给定一组纸牌,纸牌上有数字,每次把可以选择把前k个纸牌翻转过来,问,是所有纸牌从小到大的最小翻转次数最上面最小
  • 输入:每行 一组数字(从上到下)
  • 输出:初始状态,每次翻的位置,以0结束
  • 分析:每次查找位置不匹配最大值,翻到最上面,再翻到最下面
  • 方法:这里把大的放在que 的前面,方便写代码
  • 知识点:
    •         stringstream的使用
    •         max_element的使用
    •         reverse的使用
    •         distance的使用


#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;
#define CLR(x,y) memset((x),(y),sizeof((x)))
#define FOR(x,y,z) for(int (x)=(y);(x)<(z);++(x))
#define FORD(x,y,z) for(int (x)=(y);(x)>=(z);--(x))
#define FOR2(x,y,z) for((x)=(y);(x)<(z);++(x))
#define FORD2(x,y,z) for((x)=(y);(x)>=(z);--(x))
int main(){
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        string str;
        for(string str;getline(cin,str);cout<<"0\n"){
                cout<<str<<‘\n‘;
                deque<int> q;
                stringstream ss(str);
                for(int i;ss>>i;q.push_front(i)) continue;
                for(deque<int>::iterator itq = q.begin();itq != q.end();++itq){
                        deque<int>::iterator imax = max_element(itq,q.end());
                        if(imax != itq){
                                if(imax != q.end() - 1){
                                        //如果不是当前最大值不是最后的位置,那么就翻到最后的位置
                                        reverse(imax,q.end());
                                        cout<<distance(q.begin(),imax) + 1<<" ";
                                }
                                //把最后面的,翻到当前前面
                                reverse(itq,q.end());
                                cout<<distance(q.begin(),itq) + 1<<" ";
                        }                        
                }
        }
    return 0;
}  







[2016-03-03][UVA][120][Stacks of Flapjacks]

标签:

原文地址:http://www.cnblogs.com/qhy285571052/p/5243418.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!