码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1498 50 years, 50 colors(最小顶点覆盖)

时间:2014-07-26 02:44:46      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   os   strong   io   

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1507    Accepted Submission(s): 811


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it‘s so nice, isn‘t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What‘s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

bubuko.com,布布扣

 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
-1 1 2 1 2 3 4 5 -1
 

题意:一个n*n矩阵,每个格子放一个气球,气球有颜色。一个人一次可以选择一种颜色的气球,再选择一行或者一列,把该种颜色的气球踩破;

你有k次机会,看否把某种颜色的气球全部踩破。若有些颜色的气球不能被踩破,按从小大的顺序输出这些气球。否则,输出-1.

在二分图中求最少的点,让每条边都至少和其中的一个点关联,这就是二分图的“最小顶点覆盖”。

二分图的最小顶点覆盖数 =二分图的最大匹配数。

#include"stdio.h"
#include"string.h"
#define N 105
int g[N][N],vis[N];
int mark[N],link[N],n;
int find(int t,int k)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(g[k][i]==t&&!mark[i])           
        {
            mark[i]=1;
            if(link[i]==-1||find(t,link[i]))
            {
                link[i]=k;
                return 1;
            }
        }
    }
    return 0;
}
int getsum(int t)
{
    int i,cnt=0;
    memset(link,-1,sizeof(link));
    for(i=1;i<=n;i++)
    {
        memset(mark,0,sizeof(mark));
        cnt+=find(t,i);
    }
    return cnt;
}
int main()
{
    int k,i,j,t;
    while(scanf("%d%d",&n,&k),n||k)
    {
        memset(g,0,sizeof(g));
        memset(vis,0,sizeof(vis));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&t);
                g[i][j]=t;
                if(!vis[t])          //某种颜色的气球出现
                    vis[t]=1;
            }
        }
        int ans[N],cnt=0,s1;
        for(i=1;i<=50;i++)      //50种颜色的气球
        {
            if(vis[i])
            {
                s1=getsum(i);        
                if(s1>k)              //匹配数大于K则不能把气球完全踩破
                    ans[cnt++]=i;
            }
        }
        if(cnt==0)
            printf("-1\n");
        else
        {
            for(i=0;i<cnt-1;i++)
                printf("%d ",ans[i]);
            printf("%d\n",ans[cnt-1]);
        }
    }
    return 0;
}


hdu 1498 50 years, 50 colors(最小顶点覆盖),布布扣,bubuko.com

hdu 1498 50 years, 50 colors(最小顶点覆盖)

标签:des   style   http   java   color   os   strong   io   

原文地址:http://blog.csdn.net/u011721440/article/details/38117005

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!