码迷,mamicode.com
首页 > 其他好文 > 详细

CRT

时间:2014-07-26 02:46:17      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   width   

G - 中国剩余定理
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Some people believe that there are three cycles in a person‘s life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days‘‘ even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

中国剩余定理,又叫做孙子定理,是数论比较重要的定理:

给你正整数a1,a2,a3,b1,b2,b3,bi是ai对应的X取余,且Xmod ai = bi,中国剩余定理让求的就是X的值,求X(最小)的时候,运用中国剩余定理可以大大缩短时间;

先说明一个定理,这也是剩余定理的核心定理:

X1 mod a1 = b1;

X2 mod a2 = b2;

若X1 ,X2均为 最小值,那么X1+X2也是最小值,并且(X1+X2) =(这里是恒等,打不出来。。)bi (mod ai),能看出来,这是中国剩余定理的公式。这里不加证明,因为需要证明同余方程的线性运算的正确性。

因此,中国剩余定理的意义也就很明显了:求每一对同余方程的值。

每一个值的求法需要明确它的意义才能找出来;

对于每个值,需要Xi mod aj (!=i)==0&&Xi mod ai = bi;

为什么要等于0呢,对于当前值,没有这个要求,但是对于最后的值,我们要求的是对每一个子样例,满足线性同余方程,这里用反证法证明:

如果每一个不满足只对当前的值满足余数唯一,对其他值有余数,那么最后的值仍有这个性质,但最后的值仍然对这个其他的值有正确值,矛盾,假设不成立。

到这里,需要证明的全部完成。

那么如何求呢:

既然是最小的并且有约束条件,那么就从约束条件进行下手:

用到的老师刚讲的求模的一个线性运算(a * b )%c = (a%c*b%c)%c;

所以我们将Xi分解成k and n;

n = bi,so a%c = 1,and a%aj ==0 && a %c = 1;

and we should get a is the least ,we know the CRT is concernd by prime number which is ai,in other words,all the data is gcd(ai,aj) = 1,so make a circle to get k.

follow is code :

#include<cstdio>
using namespace std;
int main(void)
{
	int p, e, i, d, icase = 1;
	while (scanf("%d%d%d%d", &p, &e, &i, &d), ~p)
	{
		int n = (5544 * p + 14421 * e + 1288 * i - d + 21252) % 21252;
		if (n == 0)
			n = 21252;
        printf("Case %d: the next triple peak occurs in %d days.\n",icase++,n);
	}
	return 0;
}


CRT,布布扣,bubuko.com

CRT

标签:des   style   http   color   os   strong   io   width   

原文地址:http://blog.csdn.net/yuanhanchun/article/details/38115965

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!