码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1686 kmp

时间:2014-07-26 14:01:54      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:style   os   io   for   代码   div   ar   new   

题目:
 
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
 

 

Sample Output
1
3
0
 
 
代码:
 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn1=1000010;
const int maxn2=10010;
int n,m;
char a[maxn1];
char b[maxn2];
int next[maxn2];
int main()
{
 int kmp ( char *a,char *b,int *next);//相应的类型必须改为char型
 int t;
 cin>>t;
 while(t--)
 {
  cin>>b;//先输入短串即串2
  cin>>a;
  n=strlen(a);
  m=strlen(b);
  int ans=kmp(a,b,next);
  cout<<ans<<endl;
 }
 return 0;
}


//此函数用来求匹配串s串的next数组
void getnext (char *s,int *next)
{
    next[0]=next[1]=0;
    for (int i=1;i<m;i++)//m为匹配串s的长度
 {
        int j=next[i];
        while (j&&s[i]!=s[j])
            j=next[j];
        next[i+1]=s[i]==s[j]?j+1:0;
    }
}
//此函数用来计算串b在串a中出现的次数(a中的字母可以重复利用)
int kmp (char *a,char *b,int *next)
{
 int times=0;
    getnext (b,next);/////////
    int j=0;
    for (int i=0;i<n;i++)
 {/////n为串1的长度
        while (j&&a[i]!=b[j])
            j=next[j];
        if (a[i]==b[j])
            j++;
        if (j==m)//m为串2的长度
  {
   times++;j=next[j];//加了一个计数器和j=next[j]
  }
  if(i==n-1)
  {return times;}
    }
}


 

 

hdoj 1686 kmp,布布扣,bubuko.com

hdoj 1686 kmp

标签:style   os   io   for   代码   div   ar   new   

原文地址:http://www.cnblogs.com/weiyikang/p/3869717.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!